Open Server Manager: Power Supply Firmware Inventory Mixed Vendor Limitations

Summary: Dell Open Server Manager (OSM) web user interface (UI) Firmware Inventory cannot display multiple power supply (PSU) firmware versions when mixed vendors are populated.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Dell PowerEdge servers equipped with mixed PSU vendors only display one vendor's firmware image in the OSM web UI Firmware page. The secondary PSU firmware image is missing from the Firmware Inventory page. The missing PSU vendor cannot update the firmware image from the OSM web interface when missing from this page. 
 
OSM Web UI >> Operations >> Firmware Example:

Image 1: OSM UI Firmware Inventory Page

Other Inventory methods can be leveraged to confirm when mixed vendors are present within the system configuration.
 
OSM Web UI >> Hardware Status >> Inventory and LEDs Example:

Image 2: OSM Hardware Inventory

IPMITOOL Example:
 
ipmitool> fru print

FRU Device Description : PWR SPLY,1100W,R (ID 91)
 Board Mfg Date        : Wed May 24 22:56:00 2023 UTC
 Board Mfg             : DELL
 Board Product         : PWR SPLY,1100W,RDNT,DELTA
 Board Serial          : CNDEDXXXXXXXXX
 Board Part Number     : 0J9N6WA02

FRU Device Description : PWR SPLY,1100W,R (ID 149)
 Board Mfg Date        : Fri Mar 10 18:07:00 2023 UTC
 Board Mfg             : DELL
 Board Product         : PWR SPLY,1100W,RDNT,LTON
 Board Serial          : CNLOXXXXXXXXXX
 Board Part Number     : 0FR0KXA02

REDFISH Example:
 
GET …/redfish/v1/Chassis/Baseboard_FRU/Power


    "PowerSupplies": [
        {
            "@odata.id": "/redfish/v1/Chassis/Baseboard_FRU/Power#/PowerSupplies/0",
            "EfficiencyPercent": 90,
            "Manufacturer": "DELL",
            "MemberId": "PSU1_FRU",
            "Model": "PWR SPLY,1100W,RDNT,LTON",
            "Name": "PSU1 FRU",
            "PartNumber": "0FR0KXA02",
            "PowerInputWatts": 0.0,
            "SerialNumber": "CNLOXXXXXXXXX",
            "Status": {
                "Health": "OK",
                "State": "Enabled"
            }
        },
        {
            "@odata.id": "/redfish/v1/Chassis/Baseboard_FRU/Power#/PowerSupplies/1",
            "EfficiencyPercent": 90,
            "Manufacturer": "DELL",
            "MemberId": "PSU2_FRU",
            "Model": "PWR SPLY,1100W,RDNT,DELTA",
            "Name": "PSU2 FRU",
            "PartNumber": "0J9N6WA02",
            "PowerInputWatts": 0.0,
            "SerialNumber": "CNDEXXXXXXXXXX",
            "Status": {
                "Health": "OK",
                "State": "Enabled"
            }
        }
    ],
 

Cause

Upstream OpenBMC Firmware Inventory web UI page is limited to supporting one image per-device commodity. When mixing multiple vendors with different images, the OSM web UI only displays the firmware image from the first PSU in the system.

Resolution

This sighting is a limitation of the upstream OpenBMC firmware image. When the upstream OpenSource image is updated, Dell will incorporate into a future OSM update.
 
Workaround:
 
The REDFISH interface UpdateService can be leveraged to query the firmware inventory from each PSU individually.
 
GET …/redfish/v1/UpdateService/FirmwareInventory/psu1

{
    "@odata.id": "/redfish/v1/UpdateService/FirmwareInventory/psu1",
    "@odata.type": "#SoftwareInventory.v1_1_0.SoftwareInventory",
    "Description": "PSU image",
    "Id": "psu1",
    "Name": "Software Inventory",
    "Oem": {
        "DellOpenBMC": {
            "@odata.type": "#DellOpenBMCSoftwareInventory.v1_0_0.DellOpenBMCSoftwareInventory",
            "DellOpenBMCSoftwareInventory": {
                "InstanceType": "Installed"
            }
        }
    },
    "SoftwareId": "108858",
    "Status": {
        "HealthRollup": "OK",
        "State": "Enabled"
    },
    "Updateable": true,
    "Version": "00.21.33"
}

GET …/redfish/v1/UpdateService/FirmwareInventory/psu2

{
    "@odata.id": "/redfish/v1/UpdateService/FirmwareInventory/psu2",
    "@odata.type": "#SoftwareInventory.v1_1_0.SoftwareInventory",
    "Description": "PSU image",
    "Id": "psu2",
    "Name": "Software Inventory",
    "Oem": {
        "DellOpenBMC": {
            "@odata.type": "#DellOpenBMCSoftwareInventory.v1_0_0.DellOpenBMCSoftwareInventory",
            "DellOpenBMCSoftwareInventory": {
                "InstanceType": "Installed"
            }
        }
    },
    "SoftwareId": "108857",
    "Status": {
        "HealthRollup": "OK",
        "State": "Enabled"
    },
    "Updateable": true,
    "Version": "00.14.76"
}

Affected Products

Open Server Manager
Article Properties
Article Number: 000226480
Article Type: Solution
Last Modified: 14 Jan 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.