Otwórz aplikację Server Manager: Mieszane ograniczenia dotyczące inwentaryzacji oprogramowania wewnętrznego zasilacza

Summary: Spis oprogramowania wewnętrznego interfejsu sieciowego (UI) programu Dell Open Server Manager (OSM) nie może wyświetlać wielu wersji oprogramowania wewnętrznego zasilaczy (PSU), jeśli są one dostępne wśród różnych dostawców. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Serwery Dell PowerEdge wyposażone w zasilacze różnych dostawców wyświetlają obraz oprogramowania wewnętrznego tylko jednego dostawcy na stronie oprogramowania wewnętrznego interfejsu sieciowego OSM. Brak obrazu oprogramowania wewnętrznego dodatkowego zasilacza na stronie inwentaryzacji oprogramowania wewnętrznego. Brakujący dostawca zasilacza nie może zaktualizować obrazu oprogramowania układowego z interfejsu sieciowego OSM, gdy brakuje go na tej stronie. 
 
Interfejs >> sieciowy OSM Przykład operacyjnego >> oprogramowania układowego:


Obraz 1: Strona inwentaryzacji oprogramowania wewnętrznego interfejsu użytkownika OSM
inne metody inwentaryzacji mogą służyć do potwierdzania obecności różnych dostawców w konfiguracji systemu.
 
Przykład inwentaryzacji stanu>>sprzętu i diod LED w interfejsie >> sieciowym OSM:

Rysunek 2: Inwentaryzacja sprzętu OSM

Przykład IPMITOOL:
 
ipmitool> fru print

FRU Device Description : PWR SPLY,1100W,R (ID 91)
 Board Mfg Date        : Wed May 24 22:56:00 2023 UTC
 Board Mfg             : DELL
 Board Product         : PWR SPLY,1100W,RDNT,DELTA
 Board Serial          : CNDEDXXXXXXXXX
 Board Part Number     : 0J9N6WA02

FRU Device Description : PWR SPLY,1100W,R (ID 149)
 Board Mfg Date        : Fri Mar 10 18:07:00 2023 UTC
 Board Mfg             : DELL
 Board Product         : PWR SPLY,1100W,RDNT,LTON
 Board Serial          : CNLOXXXXXXXXXX
 Board Part Number     : 0FR0KXA02

Przykład z normą REDFISH:
 
GET …/redfish/v1/Chassis/Baseboard_FRU/Power


    "PowerSupplies": [
        {
            "@odata.id": "/redfish/v1/Chassis/Baseboard_FRU/Power#/PowerSupplies/0",
            "EfficiencyPercent": 90,
            "Manufacturer": "DELL",
            "MemberId": "PSU1_FRU",
            "Model": "PWR SPLY,1100W,RDNT,LTON",
            "Name": "PSU1 FRU",
            "PartNumber": "0FR0KXA02",
            "PowerInputWatts": 0.0,
            "SerialNumber": "CNLOXXXXXXXXX",
            "Status": {
                "Health": "OK",
                "State": "Enabled"
            }
        },
        {
            "@odata.id": "/redfish/v1/Chassis/Baseboard_FRU/Power#/PowerSupplies/1",
            "EfficiencyPercent": 90,
            "Manufacturer": "DELL",
            "MemberId": "PSU2_FRU",
            "Model": "PWR SPLY,1100W,RDNT,DELTA",
            "Name": "PSU2 FRU",
            "PartNumber": "0J9N6WA02",
            "PowerInputWatts": 0.0,
            "SerialNumber": "CNDEXXXXXXXXXX",
            "Status": {
                "Health": "OK",
                "State": "Enabled"
            }
        }
    ],
 

Cause

Strona internetowego interfejsu użytkownika inwentaryzacji oprogramowania wewnętrznego OpenBMC typu upstream jest ograniczona do obsługi jednego obrazu na urządzenie. W przypadku mieszania wielu dostawców z różnymi obrazami, sieciowy interfejs użytkownika OSM wyświetla tylko obraz oprogramowania sprzętowego z pierwszego zasilacza w systemie.

Resolution

Ta obserwacja jest ograniczeniem obrazu oprogramowania wewnętrznego OpenBMC upstream. Gdy obraz OpenSource upstream zostanie zaktualizowany, firma Dell włączy go do przyszłej aktualizacji OSM.
 
Obejście problemu:
 
Za pomocą usługi aktualizacji interfejsu REDFISH można wysyłać zapytanie o zasoby oprogramowania wewnętrznego z każdego zasilacza z osobna.
 
GET …/redfish/v1/UpdateService/FirmwareInventory/psu1

{
    "@odata.id": "/redfish/v1/UpdateService/FirmwareInventory/psu1",
    "@odata.type": "#SoftwareInventory.v1_1_0.SoftwareInventory",
    "Description": "PSU image",
    "Id": "psu1",
    "Name": "Software Inventory",
    "Oem": {
        "DellOpenBMC": {
            "@odata.type": "#DellOpenBMCSoftwareInventory.v1_0_0.DellOpenBMCSoftwareInventory",
            "DellOpenBMCSoftwareInventory": {
                "InstanceType": "Installed"
            }
        }
    },
    "SoftwareId": "108858",
    "Status": {
        "HealthRollup": "OK",
        "State": "Enabled"
    },
    "Updateable": true,
    "Version": "00.21.33"
}

GET …/redfish/v1/UpdateService/FirmwareInventory/psu2

{
    "@odata.id": "/redfish/v1/UpdateService/FirmwareInventory/psu2",
    "@odata.type": "#SoftwareInventory.v1_1_0.SoftwareInventory",
    "Description": "PSU image",
    "Id": "psu2",
    "Name": "Software Inventory",
    "Oem": {
        "DellOpenBMC": {
            "@odata.type": "#DellOpenBMCSoftwareInventory.v1_0_0.DellOpenBMCSoftwareInventory",
            "DellOpenBMCSoftwareInventory": {
                "InstanceType": "Installed"
            }
        }
    },
    "SoftwareId": "108857",
    "Status": {
        "HealthRollup": "OK",
        "State": "Enabled"
    },
    "Updateable": true,
    "Version": "00.14.76"
}

Affected Products

Open Server Manager
Article Properties
Article Number: 000226480
Article Type: Solution
Last Modified: 14 Jan 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.