Avamar: Backup Failed After Enabling Data Domain Retention Lock Governance Mode

Summary: This article discusses when enabling Data Domain retention lock in governance mode on Avamar 19.10 causes VMware image backups to fail due to insufficient privileges.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

After enable Data Domain Governance Mode, the VMware image backups start to fail with the following error message:

2024-11-07 20:36:29 avtar Warning <18125>: Calling DDR_RENAME returned result code:5034 message:the user has insufficient privilege
2024-11-07 20:36:29 avtar Info <40069>: Backup /cur/a510971916cf1c1b79c2608fec07b1bdc16af533/1DB3154E8295112 has 9 files on the Data Domain server
2024-11-07 20:36:29 avtar Error <19802>: Failed to rename backup dir /STAGING/a510971916cf1c1b79c2608fec07b1bdc16af533/BACKUP-0CD272DAA94BD828804C4F6B9F1154E55A76A1B3 to /cur/a510971916cf1c1b79c2608fec07b1bdc16af533/1DB3154E8295112, LSU: avamar-1234567890, DDR result code: 5034, desc: the user has insufficient privilege
2024-11-07 20:36:29 avtar FATAL <12531>: Backup could not be committed to the DDR, hfscheck will fail. This backup id 0x1DB3154E8295112 for client a510971916cf1c1b79c2608fec07b1bdc16af533 should be deleted from the Avamar accounting system to resolve hfscheck errors.
2024-11-07 20:36:29 avtar FATAL <40124>: DDR rename failure - backup will be deleted
2024-11-07 20:36:29 avtar Warning <40126>: Unable to delete invalid backup #430 timestamp 133754854679597330: 'MSG_ERR_PRIV_FAIL'

This error can also occur for guest backups such as Windows, Linux file system, database, so forth.

 

Cause

The governance mode is not configured in the Avamar server side.

In this specific case, the Avamar proxy version is 19.4 and hence it does not support this feature:

--------------------------------------------------------------------------------------------------------
-----  START avtar log 2024-11-07 20:34:33 UTC  [19.4.100-124 Linux-x86_64]
--------------------------------------------------------------------------------------------------------

 

 

 

Resolution

Carefully read the Dell Avamar 19.10 Administration Guide > Data Domain Retention Lock > Enable Data Domain retention lock in governance mode.

Upgrade the proxy or the Avamar client to 19.10 version.

Note: If unsure about the upgrade process or concerned, contact Dell Support for assistance.

 

To verify that the issue has been successfully resolved, check the Avamar logs for any error messages related to Data Domain retention lock. If the issue persists, contact Dell Support for further assistance.

Affected Products

Avamar, Data Domain, Avamar Server
Article Properties
Article Number: 000261098
Article Type: Solution
Last Modified: 12 Dec 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.