PowerFlex: SRM array disconnected after PowerFlex upgrade from 3.6 to 4.5 +
Summary: After upgrade PowerFlex systems from 3.6 to 4.5 +, SRM arrays got disconnected and SRM does not work.
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Symptoms
SRM Array disconnected and showing ping errors between SRM and PowerFlex Gateway, as show the error: SRA command 'discoverDevices' failed
Cause
PowerFlex 4.5 + changed the external gateway VM to an internal container within PowerFlex Manager. Due to this, SRM lost the connectivity, as gateway IP changes to the internal container network.
Resolution
When upgrading PowerFlex from 3.6 to 4.5 + it is needed to follow the following actions:
1 - Upgrade SRA to at least version 1.0.1: https://dl.dell.com/content/manual67010541-dell-powerflex-storage-replication-adapter-sra-plugin-for-vmware-live-site-recovery.pdf?language=en-us
2 - Change the array configuration at SRM to point to PowerFlex Manager FQDN/IP.
After those actions, SRM should start to work back again.
Affected Products
PowerFlex Appliance, Storage Replication Adapter (SRA)Article Properties
Article Number: 000322280
Article Type: Solution
Last Modified: 03 Jul 2025
Version: 2
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