NetWorker: Microsoft Entra ID 사용 시 VMware vCenter 인증 실패
Summary: VMware vCenter Server는 AD 계정을 사용하여 NetWorker에 추가됩니다. vCenter는 Azure Entra ID와 통합되며 NetWorker 내에서 사용되는 계정은 Entra ID에서 가져옵니다. VMware vCenter를 통한 NetWorker 인증이 실패하여 인벤토리 처리 및 NVP(NetWorker VMware Protection) 백업이 실패합니다. ...
Symptoms
VMware vCenter는 도메인 계정을 사용하여 NetWorker에 추가됩니다.
NetWorker 인벤토리(nsrvim)에 실패합니다. 이후 NVP(NetWorker VMware Protection) VM(Virtual Machine) 백업 워크플로가 실패합니다. NetWorker Server의 데몬 로그에서 다음 오류가 발견됩니다.
- Linux:
/nsr/logs/daemon.raw - Windows(기본값):
C:\Program Files\EMC NetWorker\nsr\logs\daemon.raw - NetWorker: nsr_render_log 사용하여 .raw 로그 파일을 렌더링하는 방법
MM/DD/YY HH:mm:SS 1 3 0 1861961472 3051286 0 NW_SERVER_NAME nsrdisp_nwbg RAP notice job 'nsrvim' progress message: Cannot complete login due to an incorrect user name or password..
자격 증명이 올바르며 vSphere Web Client에 로그인하는 데 사용할 수 있습니다.
VMware vCenter의 도메인 통합은 Azure Entra ID를 사용합니다. 본보기: vCenter Server
용 Microsoft Entra ID 구성vCenter Server의 /var/log/vmware/vpxd/vpxd.log 다음을 표시합니다.
YYYY-HH-MMTHH:mm:SSZ error vpxd[06328] [Originator@6876 sub=UserDirectorySso opID=OPERATION_ID] AcquireToken exception: N9SsoClient27InvalidCredentialsExceptionE(Authentication failed: Invalid credentials) --> [context]zKq7AVEC-TOKEN_STRING-8uNgA=[/context] YYYY-HH-MMTHH:mm:SSZ error vpxd[06328] [Originator@6876 sub=User opID=OPERATION_ID] Failed to authenticate user <DOMAIN_USERNAME@DOMAIN>
Cause
NetWorker는 VMware API와 상호 작용할 때 기본 인증을 활용하며 AD/LDAP 기반 인증 메커니즘만 지원합니다.
Microsoft Entra ID(이전의 Azure AD)는 NetWorker에서 지원하지 않는 인증 방법을 사용하는 클라우드 기반 ID 플랫폼입니다.
Resolution
RFE(Request For Enhancement) NetWorker에서 VMware vCenter 리소스에 대한 Entra ID 인증을 지원하도록 요청하는 iZone 292 가 열렸습니다. 이 RFE를 추적하려면 이 RFE와 관련하여 Dell 어카운트 또는 영업 담당자에게 문의하십시오.
해결 방법:
기본 AD/LDAP 기반 인증 계정을 구성할 수 없는 경우 VMware SSO(Single Sign On) 계정을 생성하고 이를 사용하여 VMware 내에서 NetWorker를 인증합니다. 계정에 필요한 사용 권한은 NetWorker VMware 통합 가이드의 전용 vCenter 사용자 계정 생성 섹션에 설명되어 있습니다. NetWorker 지원 | 매뉴얼 및 문서
Additional Information
VMware를 통한 Microsoft Entra ID 인증에 대한 지원을 NetWorker에 추가하려면 Dell 영업 담당자 또는 어카운트 담당자에게 개선 요청에 대해 문의하십시오.