Dell Latitude and Pro Plus Laptops webcam Lags Using Teams

Summary: The following article provides information about an intermittent video lag seen on Teams conference calls. This is affecting the integrated webcam on Dell Latitude and Pro Plus laptops. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

There are reports of the integrated webcam on Dell Latitude and Pro Plus laptops intermittently lagging and stuttering for a couple of seconds before recovering. This occurs intermittently at the beginning or during a conference call using video.

Affected Platforms:

  • Dell Pro 13 Plus PB13250
  • Dell Pro 14 Plus PB14250
  • Dell Pro 16 Plus PB16250
  • Latitude 7350
  • Latitude 7350 Detachable
  • Latitude 7450
  • Latitude 9450 2-in-1

Cause

Triggering the Intel intelligent bias control (IBC) ratio limits the graphical processor unit (GPU) processing power and has a direct impact on its performance. The lagging effect is most visible on high GPU workloads. (Workloads include the mobile industry processor interface (MIPI), high dynamic range (HDR) background filtering, and video streaming combined.)

Resolution

Note: This solution alleviates the frequency of the lagging and is highly dependent on the graphical workload.

Dell Engineering and Intel have adjusted the IBC to provide more processing power to the GPU.

Note: Before starting the update, perform the following:
  1. Back up all personal data. For more information, refer to: Back Up and Recovery

  2. Connect the AC adapter.

Update driver for Dell Pro 13 Plus PB13250, Dell Pro 16 Plus PB16250, and Latitude 7350:

Updating the Intel graphics driver to version 32.0.101.8132 or later on the laptop resolves the issue. To download and install the Intel-Graphics-Arc-Graphics-Driver-and-Intel-Graphics_KMR43_WIN64_32.0.101.8132_A06.exe file, refer to: The Driver Update Guide

Update driver for Latitude 7350 detachable:

Updating the Intel graphics driver to version 32.0.101.8132 or later on the laptop resolves the issue. To download and install the Intel-Graphics-Intel-Iris-Xe-Graphics-Driver-and_XTMF3_WIN64_32.0.101.8132_A07.exe file, refer to: The Driver Update Guide

Update driver for Dell Pro 14 Plus PB14250, Latitude 7450, and Latitude 9450 2-in-1:

Updating the Intel graphics driver to version 32.0.101.8132 or later on the laptop resolves the issue. To download and install the Intel-Graphics-UHD-Iris-Xe-Arc-Arc-Pro-Graphics-Driver_85T1X_WIN64_32.0.101.8132_A00.exe file, refer to: The Driver Update Guide

Affected Products

Dell Pro 13 Plus PB13250, Dell Pro 14 Plus PB14250, Dell Pro 16 Plus PB16250, Latitude 7350, Latitude 7350 Detachable, Latitude 7450, Latitude 9450 2-in-1
Article Properties
Article Number: 000390161
Article Type: Solution
Last Modified: 19 Nov 2025
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.