Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Create and access a list of your products

Dell EMC Unity: Unisphere GUI fails intermittently (User Correctable)

Summary: Unisphere GUI fails often and take a long time to respond.

This article applies to   This article does not apply to 

Symptoms



Unisphere GUI fails often and take a long time to respond.

Restarting Management Services solves the issue, only temporarily.

Cause

Too many /api/types requests from multiple Virtual Machines cause this issue.

Resolution

The Unity Administrator must investigate which Hosts are overflooding the Unity Array with these requests.

As a temporary solution, Management Service can be restarted, as per Article Number 000490488.

However, for a permanent resolution, Hosts and their respective Virtual Machines must be halted and investigated, as these are the cause of the issue.

For further assistance or clarification on this issue, please contact Support and refer Article Number 000541664.

Additional Information

This behavior can be confirmed by looking up the amount of /api/types request being logged at the access_log.
It can be verified with the below command:
 
service@spa:~/user# grep -i "GET /api/types" /nas/http/logs/access_log | wc -l
3873

To identify which Hosts are responsible for these requests you may use the command below:
 
service@spa:~/user# cat /nas/http/logs/access_log | grep -i  "/api/types/loginSessionInfo"
10.60.15.70 - - [19/Mar/2020 06:45:42.597172] 2548 [19/Mar/2020 06:45:42.599720] "GET /api/types/loginSessionInfo/instances HTTP/1.1" 302 294 "-" "-" "-"
10.60.15.70 - - [19/Mar/2020 06:46:43.305886] 2195 [19/Mar/2020 06:46:43.308081] "GET /api/types/loginSessionInfo/instances HTTP/1.1" 302 294 "-" "-" "-"
10.60.15.70 - - [19/Mar/2020 06:47:43.964377] 2591 [19/Mar/2020 06:47:43.966968] "GET /api/types/loginSessionInfo/instances HTTP/1.1" 302 294 "-" "-" "-"
10.60.15.70 - - [19/Mar/2020 06:48:44.750100] 2362 [19/Mar/2020 06:48:44.752462] "GET /api/types/loginSessionInfo/instances HTTP/1.1" 302 294 "-" "-" "-"
10.60.15.70 - - [19/Mar/2020 06:49:45.415558] 2575 [19/Mar/2020 06:49:45.418133] "GET /api/types/loginSessionInfo/instances HTTP/1.1" 302 294 "-" "-" "-"
10.60.15.70 - - [19/Mar/2020 06:50:46.090056] 3108 [19/Mar/2020 06:50:46.093164] "GET /api/types/loginSessionInfo/instances HTTP/1.1" 302 294 "-" "-" "-"
10.60.15.70 - - [19/Mar/2020 06:51:46.763939] 2181 [19/Mar/2020 06:51:46.766120] "GET /api/types/loginSessionInfo/instances HTTP/1.1" 302 294 "-" "-" "-"
As we can see at the example above, Host holding IP Address 10.60.15.70 is one of the many causing the issue.

Affected Products

Dell EMC Unity Family

Products

Dell Unity 300, Dell EMC Unity 300F, Dell EMC Unity 350F, Dell EMC Unity XT 380, Dell EMC Unity XT 380F, Dell EMC Unity 400, Dell EMC Unity 400F, Dell EMC Unity 450F, Dell EMC Unity XT 480, Dell EMC Unity XT 480F, Dell EMC Unity 500 , Dell EMC Unity 500F, Dell EMC Unity 550F, Dell EMC Unity 600, Dell EMC Unity 600F, Dell EMC Unity 650F, Dell EMC Unity XT 680, Dell EMC Unity XT 680F, Dell EMC Unity XT 880, Dell EMC Unity XT 880F, Dell EMC Unity Family |Dell EMC Unity All Flash, Dell EMC Unity Family, Dell EMC Unity Hybrid, Dell EMC UnityVSA Professional Edition/Unity Cloud Edition ...