OpenManage Enterprise: Important notice concerning the 4.4.0 upgrade failure
Summary: An issue has been identified where after upgrading to OpenManage Enterprise 4.4.0 the web user interface (UI) is no longer accessible. The web UI looks to be stuck on 'Installing the packages' or 'Loading…Services are starting up' or 'Some or all of the services are down.' Monitoring the operating system start from the virtual console shows that the Docker Application Container Engine service fails to start. ...
Symptoms
The appliance restarts to initialize and enable the upgraded packages after completing the update to version 4.4.0. Under normal circumstances the Text User Interface (TUI) loads the core services at startup, and the post upgrade task completes the upgrade.
However, it is noted in some instances that the Docker Application Container Engine service fails to start after the first reboot. In these instances, the following is seen:
The web user interface is stuck with the message 'Installing the package…' for several hours.

The web user interface stuck with the message 'Loading…Services are starting up.' for several hours.

The appliance virtual console shows docker service failing to start.

The Text User Interface (TUI) will load after the service-start timeouts are exceeded. However, the web interface shows 'Some or all of the services are down.' and the TUI appliance status windows indicates multiple services as 'inactive.'

Launching the TUI, selecting 'Display Current Appliance Status' and then selecting 'Continue shows most services as inactive.

Cause
OpenManage Enterprise leverages Docker to virtualize (containerize) several core applications. Docker uses an internal interface to allow network communication for these containerized applications. During initialization, the Docker interface is moved into a dedicated firewall zone to isolate this traffic from the primary interface.
However, after completing a previous upgrade to either version 4.2.x or 4.3.x the Docker interface is moving out of the dedicated zone. This disallows network communication and interferes with the start of the service the next time the service is updated.
If an appliance restart is not triggered between the previous and current update execution, the Docker service fails to start, and the appliance is inaccessible.
Resolution
As of May 01, 2025, the 4.4.0 upgrade has been removed from the OpenManage Enterprise online update catalog. The upgrade version 4.4.1, released May 23, 2025, contains the Docker interface fix. New deployments of OpenManage Enterprise version 4.4.0 appliance are not impacted and remain available for download on www.dell.com. If you have successfully upgraded to version 4.4.0, no further action is required.