Dell Unity:無法連線至 LDAP 伺服器。重新檢查目錄服務底下的 LDAP 組態。(錯誤代碼:0x6000193) [可由使用者更正]

Summary: 無法設定 LDAP 和 LDAPS -- 連線驗證失敗。

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms


無法連線至 LDAP 伺服器。重新檢查目錄服務底下的 LDAP 組態。(錯誤代碼:0x6000193)

LDAP 組態畫面

 
 

Cause

  • 不正確的 LDAP 伺服器詳細資料 |LDAP 伺服器無法連線 
  • 不正確的系結使用者 DN 和密碼
  • 如果使用 LDAPS,則不正確的 LDAP 伺服器 SSL 憑證



Resolution

LDAP 伺服器詳細資料
LDAP 伺服器必須使用主機名稱和 IP 位址從 Unity 進行 ping。

C:\Users\user>nslookup
Server:  peeps-dc.peeps.lab - - > > >peeps-dc 是主機名稱 || peeps.lab 是功能變數名稱
位址:  5.6.xx.xx

名稱:    peeps-dc.peeps.lab
位址:  5.6.xx.xx
C:\Users\user>


Incorrect Bind user DN and Password
From your windows host machine the ad run the below command in cmd and search for the username for find the Distinguished name for the user.

C:\Users\Administrator>setspn LdapUser
Registered ServicePrincipalNames for CN=LdapUser、CN=Users、DC=peeps、DC=lab
C:\Users\Administrator> CN=LdapUser、CN=Users、DC=peeps、DC=lab - > > >如果使用 LDAPS
,這是系結使用者

不正確的 LDAP 伺服器 SSL 憑證的 Distingued 名稱

上傳 SSL 憑證後,驗證連線、連線失敗,可從 ldapsearch 輸出驗證。

Ldapsearch測試 LDAP 聯
ldapsearch -x -d 1 -v -H ldap://ldapserver_name_or_IP:389 -b 「CN=Users,dc=peeps,dc=lab」 -D 「CN=Administrator,CN=Users,DC=peeps,DC=lab」 -w 密碼

成功搜尋部分輸出:

# 篩選器:(objectclass=*)
# 要求:ALL
#
res_errno:0、res_error: ldap_free_request (origid 2、msgid 2)


如果網網域控制站上的原則為:「網網域控制站:若未設定為在 Unisphere 上使用 SSL 與 LDAPS 選項,LDAP 伺服器簽章要求」設為「需要簽署」,則連線會失敗。

如果您的 LDAP 伺服器需要驗證,而您嘗試設定 LDAP,而非 LDAPS 而不上傳 SSL,以下是要驗證相同的 ldapsearch 輸出。
res_errno:8、res_error:、res_matched:

Ldapsearch測試 LDAPS 連線

env LDAPTLS_CACERT=/EMC/backend/CEM/LDAPIe/serverCertsearch.cer ldapsearch -x -d 1 -v -H ldaps://ldapserver_name_or_IP:636 -b 「CN=Users,dc=peeps,dc=lab」 -D 「CN=Administrator,CN=Users,DC=peeps,DC=lab」 -w Password

如果 SSL 不正確,則 LDAPS 的 ldapsearch 輸出如下。

TLS 追蹤:SSL_connect:SSLv3/TLS 寫入用戶端 Hello
TLS 追蹤:SSL_connect:SSLv3/TLS 讀取伺服器 Hello
TLS 憑證驗證:深度:1、err:20,主題:/DC=lab/DC=peeps/CN=issuer_name,簽發者:/CN=issuer_name
TLS 憑證驗證:錯誤,無法取得本機簽發者憑證
tls_write:want=7、written=7
  0000:  15 03 03 00 02 02 30 ......0
TLS 追蹤:SSL3 警示寫入:嚴重:不明 CA
TLS 追蹤:SSL_connect:錯誤
TLS:無法連線:錯誤:1416F086:SSL 例行程式:tls_process_server_certificate:憑證驗證失敗 (無法取得本機簽發者憑證)。 
ldap_err2string
ldap_sasl_bind (簡單):無法聯絡 LDAP 伺服器 (-1)
警告 Unity 服務 Shell 已啟動!警告***
root@hostname spa:/home/service/user#

Affected Products

Dell EMC Unity, Dell Unity 300, Dell EMC Unity 300F, Dell EMC Unity 350F, Dell EMC Unity 400, Dell EMC Unity 400F, Dell EMC Unity 450F, Dell EMC Unity 500, Dell EMC Unity 500F, Dell EMC Unity 550F

Products

Dell EMC Unity XT 380, Dell EMC Unity XT 380F, Dell EMC Unity XT 480, Dell EMC Unity XT 480F, Dell EMC Unity 600, Dell EMC Unity 600F, Dell EMC Unity 650F, Dell EMC Unity XT 680, Dell EMC Unity XT 680F, Dell EMC Unity XT 880, Dell EMC Unity XT 880F , Dell EMC Unity Family |Dell EMC Unity All Flash, Dell EMC Unity Family, Dell EMC Unity Hybrid, Dell EMC UnityVSA Professional Edition/Unity Cloud Edition ...
Article Properties
Article Number: 000211909
Article Type: Solution
Last Modified: 12 Dec 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.