Dell Unity:无法连接到 LDAP 服务器。在 目录服务 下重新检查您的 LDAP 配置。(Error Code: 0x6000193) [用户可更正]
Summary: 无法配置 LDAP 和 LDAPS — 连接验证失败。
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Symptoms
无法连接到 LDAP 服务器。在 目录服务 下重新检查您的 LDAP 配置。(Error Code: 0x6000193)
Cause
- 错误的 LDAP 服务器详细信息 |LDAP 服务器无法访问
- 绑定用户 DN 和密码不正确
- 如果使用 LDAPS,则 LDAP 服务器 SSL 证书不正确
Resolution
LDAP 服务器详细信息
必须使用主机名和 IP 地址从 Unity ping LDAP 服务器。
C:\Users\user>nslookup
Server: peeps-dc.peeps.lab - - > > >peeps-dc 是主机名 || peeps.lab 是域名
地址: 5.6.xx.xx
名称: peeps-dc.peeps.lab
地址: 5.6.xx.xx
C:\Users\user>
Incorrect Bind user DN and Password
从加入 AD 的 Windows 主机中运行以下命令,并在 cmd 中搜索用户名以查找用户的可分辨名称。
C:\Users\Administrator>setspn LdapUser
Registered ServicePrincipalNames for CN=LdapUser,CN=Users,DC=peeps,DC=lab
C:\Users\Administrator>CN=LdapUser,CN=Users,DC=peeps,DC=lab - - > > > 这是绑定用户
的禁用名称如果使用 LDAPS,则错误的 LDAP 服务器 SSL 证书
上传 SSL 证书后,验证连接,连接失败,这可以从 ldapsearch 输出进行验证。
用于测试 LDAP 连接
的 Ldapsearchldapsearch -x -d 1 -v -H ldap://ldapserver_name_or_IP:389 -b “CN=Users,dc=peeps,dc=lab” -D “CN=Administrator,CN=Users,DC=peeps,DC=lab” -w 密码
成功搜索输出的一部分:
# 筛选器:(objectclass=*)
请求编号:ALL
#
res_errno:0、res_error: ldap_free_request(origid 2、msgid 2)
如果域控制器上的策略为:“域控制器:LDAP 服务器签名要求“设置为”需要签名“,如果不配置为在 Unisphere 上将 SSL 与 LDAPS 选项配合使用,连接将失败。
如果您的 LDAP 服务器需要身份验证,并且您尝试配置 LDAP,而不是 LDAPS 而不上传 SSL,则下面是 ldapsearch 输出以验证相同。
用于测试 LDAPS 连接的 Ldapsearch
必须使用主机名和 IP 地址从 Unity ping LDAP 服务器。
C:\Users\user>nslookup
Server: peeps-dc.peeps.lab - - > > >peeps-dc 是主机名 || peeps.lab 是域名
地址: 5.6.xx.xx
名称: peeps-dc.peeps.lab
地址: 5.6.xx.xx
C:\Users\user>
Incorrect Bind user DN and Password
从加入 AD 的 Windows 主机中运行以下命令,并在 cmd 中搜索用户名以查找用户的可分辨名称。
C:\Users\Administrator>setspn LdapUser
Registered ServicePrincipalNames for CN=LdapUser,CN=Users,DC=peeps,DC=lab
C:\Users\Administrator>CN=LdapUser,CN=Users,DC=peeps,DC=lab - - > > > 这是绑定用户
的禁用名称如果使用 LDAPS,则错误的 LDAP 服务器 SSL 证书
上传 SSL 证书后,验证连接,连接失败,这可以从 ldapsearch 输出进行验证。
用于测试 LDAP 连接
的 Ldapsearchldapsearch -x -d 1 -v -H ldap://ldapserver_name_or_IP:389 -b “CN=Users,dc=peeps,dc=lab” -D “CN=Administrator,CN=Users,DC=peeps,DC=lab” -w 密码
成功搜索输出的一部分:
# 筛选器:(objectclass=*)
请求编号:ALL
#
res_errno:0、res_error: ldap_free_request(origid 2、msgid 2)
如果域控制器上的策略为:“域控制器:LDAP 服务器签名要求“设置为”需要签名“,如果不配置为在 Unisphere 上将 SSL 与 LDAPS 选项配合使用,连接将失败。
如果您的 LDAP 服务器需要身份验证,并且您尝试配置 LDAP,而不是 LDAPS 而不上传 SSL,则下面是 ldapsearch 输出以验证相同。
res_errno:8、res_error:res_matched:
用于测试 LDAPS 连接的 Ldapsearch
env LDAPTLS_CACERT=/EMC/backend/CEM/LDAPCer/serverCertificate.cer ldapsearch -x -d 1 -v -H ldaps://ldapserver_name_or_IP:636 -b “CN=Users,dc=peeps,dc=lab” -D “CN=Administrator,CN=Users,DC=peeps,DC=lab” -w 密码
如果 SSL 不正确,则在 ldapsearch for LDAPS 上显示以下输出。 TLS 跟踪:SSL_connect:SSLv3/TLS 写入客户端问候 TLS 跟踪:SSL_connect:SSLv3/TLS 读取服务器 hello TLS 证书验证:深度:1,错误:20,主题:/DC=lab/DC=peeps/CN=issuer_name,颁发者:/CN=issuer_name TLS 证书验证:错误,无法获取本地颁发者证书 tls_write:want=7,written=7 0000: 15 03 03 00 02 02 30 ......0 TLS 跟踪:SSL3 警报写入:致命:未知 CA TLS 跟踪:SSL_connect:出错 TLS:无法连接:error:1416F086:SSL routines:tls_process_server_certificate:certificate verify failed(无法获取本地颁发者证书)。 ldap_err2string ldap_sasl_bind(简单):无法联系 LDAP 服务器 (-1) 警告 · Unity 服务 shell 已激活!警告*** root@hostname spa:/home/service/user#
Affected Products
Dell EMC Unity, Dell Unity 300, Dell EMC Unity 300F, Dell EMC Unity 350F, Dell EMC Unity 400, Dell EMC Unity 400F, Dell EMC Unity 450F, Dell EMC Unity 500, Dell EMC Unity 500F, Dell EMC Unity 550FProducts
Dell EMC Unity XT 380, Dell EMC Unity XT 380F, Dell EMC Unity XT 480, Dell EMC Unity XT 480F, Dell EMC Unity 600, Dell EMC Unity 600F, Dell EMC Unity 650F, Dell EMC Unity XT 680, Dell EMC Unity XT 680F, Dell EMC Unity XT 880, Dell EMC Unity XT 880F
, Dell EMC Unity Family |Dell EMC Unity All Flash, Dell EMC Unity Family, Dell EMC Unity Hybrid, Dell EMC UnityVSA Professional Edition/Unity Cloud Edition
...
Article Properties
Article Number: 000211909
Article Type: Solution
Last Modified: 12 Dec 2025
Version: 3
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