DRM: Custom repositories are missing DUPs when created using OpenManage Enterprise Integration feature with DRM 3.4

Summary: Custom repositories created using the OpenManage Enterprise (OME) Integration feature in Dell Repository Manager (DRM) may be missing random firmware DUPs.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

It may be noticed that OpenManage Enterprise, while viewing a Firmware/Driver Compliance report that certain expected device firmware for a given discovered host are listed with Unknown status and "Update file not found in catalog.” This may occur if the custom Catalog was created with DRM using the OpenManage Enterprise Integration feature that collects specific device inventory information for a group of hosts that are defined in OpenManage Enterprise.

Cause

Dell Engineering is investigating where a given host’s iDRAC is not collecting a critical ComponentID data element during Lifecycle inventory that is necessary to compare against the component versioning in the Catalog. This missing element is more often found with storage devices like BOSS controllers, and NVMe drives but has also been sporadically found with some Intel NICs and other less common devices.

OpenManage Enterprise’s compliance algorithm uses PCI device IDs as an alternative to missing ComponentID. However, PCI ID info is not passed to DRM as part of the OpenManage Enterprise Integration feature so the DUP cannot be resolved from the DRM source catalog and will be omitted from the custom repository.

Resolution

In some instances, a simple iDRAC reset at the affected host can resolve this missing ComponentID data needed further in the DRM process. After an iDRAC reset an Inventory refresh must then be initiated in OpenManage Enterprise. Once the inventory is complete then in DRM select the repository that is created with OpenManage Enterprise Integration, click the Refresh button, and verify connection and credentials to the OpenManage Enterprise appliance. A new Catalog must be exported from the repository and the OpenManage Enterprise baseline that is updated to reference the refreshed custom Catalog.

Affected Products

Dell OpenManage Enterprise, Repository Manager, Dell EMC OpenManage Enterprise
Article Properties
Article Number: 000206094
Article Type: Solution
Last Modified: 10 Jul 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.