PowerScale: NFS Intermittently Fails to Insert Export Post Cluster Reboot Leading to Client Mount Failure
Summary: Network File System (NFS) fails to insert exports after upgrade or reboot leading to NFS client failing to mount NFS shares with an error "No such file or directory."
Symptoms
Clients attempting to mount or perform an operation on a previously used export receive this error:
# mount -F nfs example.com:/ifs/testexport /tmp nfs mount: example.com:/ifs/testexport: No such file or directory # cd /test -bash: cd: /test: No such file or directory
The following messages may be seen in the nfs.log. Aliases fail to insert the export since the path entries are not present under the LIN tree:
TESTCLUSTER-21 nfs[4900]: [nfs] Failed to insert "/ifs/testexport" for export 36 with status 0xc0000467(STATUS_FILE_NOT_AVAILABLE) TESTCLUSTER-21 nfs[4900]: [nfs] Problem inserting alias /testexport 0xc0000467 (STATUS_FILE_NOT_AVAILABLE)
Cause
There is a relatively low chance of running into this issue, but it has been seen when clusters simultaneously reboot (upgrade, patch install, so on). During NFS start, a syscall is issued to open and load the export. There is a rare chance that the syscall may fail due to the simultaneous reboot, which leads to the failure of loading one or more exports.
Resolution
A potential workaround is to run a rolling reboot instead of a simultaneous reboot. For example, instead of a simultaneous upgrade, run a rolling upgrade.
To resolve this issue, reload the affected zones. This should be non-disruptive.
isi nfs exports reload --zone=<zone of affected exports>
If the above command does not provide relief, contact Dell PowerScale Support to troubleshoot the issue.
This issue is addressed in the following versions:
- OneFS 9.2.1.25 and later
- OneFS 9.4.0.16 and later
- OneFS 9.5.0.7 and later