NetWorker Management Console: Intermittently GST Service stop require multiple restarts

Summary: The GST service stops intermittently and requires multiple restarts to log in.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Intermittently GST Service stop functioning require multiple restarts to log in to the NMC.

Cause

The NetWorker Management Console (NMC) database is inconsistent, or access to it fails intermittently.

GST log may shows following errors.

0 16/10/2016 2:36:15 AM  1 5 0 xxxxxxxx test.lab.local gstd NSR notice 10/16/16 02:36:15.xxxxxx The most recently called subfunction returned error 2.
0 16/10/2016 2:36:15 AM  1 5 0 xxxxxxxx test.lab.local gstd NSR notice 10/16/16 02:36:15.xxxxxx D:/views/nw/9.0.1/gst/modules/psm2/tsc_man_evnt.c(914): Internal error: ODBC problem.
0 16/10/2016 2:36:15 AM  1 5 0 xxxxxxxx test.lab.local gstd NSR notice 10/16/16 02:36:15.xxxxxx       ODBC environment handle:
0 16/10/2016 2:36:15 AM  1 5 0 xxxxxxxx test.lab.local gstd NSR notice 10/16/16 02:36:15.xxxxxx       ODBC database connection handle:
0 16/10/2016 2:36:15 AM  1 5 0 xxxxxxxx test.lab.local gstd NSR notice 10/16/16 02:36:15.xxxxxx       ODBC statement handle:
0 16/10/2016 2:36:15 AM  1 5 0 xxxxxxxx test.lab.local gstd NSR notice 10/16/16 02:36:15.xxxxxx The most recently called subfunction returned error 2.
0 16/10/2016 2:36:15 AM  1 5 0 xxxxxx test.lab.local gstd NSR notice 10/16/16 02:36:15.xxxxxx poll: ERROR, failed to store_fetch from database



0 27/02/2017 8:05:16 AM  1 5 0 xxxxxxxx test.lab.local gstd NSR notice 02/27/17 08:05:16.xxxxxx Out of memory.
0 27/02/2017 8:05:16 AM  1 5 0 xxxxxxxx test.lab.local gstd NSR notice 02/27/17 08:05:16.xxxxxx Could not add attribute 'poll_private'.
0 27/02/2017 8:05:16 AM  1 5 0 xxxxxxxx test.lab.local gstd NSR notice 02/27/17 08:05:16.xxxxxx Out of memory.
0 27/02/2017 8:05:16 AM  1 5 0 xxxxxxxx test.lab.local gstd NSR notice 02/27/17 08:05:16.xxxxxx The most recently called subfunction returned error 2.
0 27/02/2017 8:05:16 AM  1 5 0 xxxxxxxx test.lab.local gstd NSR notice 02/27/17 08:05:16.xxxxxx The most recently called subfunction returned error 2.
0 27/02/2017 8:05:16 AM  1 5 0 xxxxxxxx test.lab.local gstd NSR notice 02/27/17 08:05:16.xxxxxx The most recently called subfunction returned error 2.
0 27/02/2017 8:05:16 AM  1 5 0 xxxxxxxx test.lab.local gstd NSR notice 02/27/17 08:05:16.xxxxxx The most recently called subfunction returned error 2.
0 27/02/2017 8:05:16 AM  1 5 0 xxxxxxxx test.lab.local gstd NSR notice 02/27/17 08:05:16.xxxxxx end of processing msg 'psm/fetch' rescode 2    reason: 'Out of memory.'

Resolution

Installing NMC on another host to verify reinstall resolve the problem.

Procedure to reinstall NMC server.

  • Uninstall NetWorker Management Console (NMC) - Do not uninstall Networker server software
  • Rename the NMC folder ('Management' folder).
  • Install NetWorker Management Console (NMC) again and configure it.

If there are recent good NMC database backups available, restoring NMC database may help.

Affected Products

NetWorker Management Console

Products

NetWorker Management Console
Article Properties
Article Number: 000065433
Article Type: Solution
Last Modified: 15 Aug 2025
Version:  4
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