PowerStore: WebUI (UI) nach unterbrechungsfreiem Upgrade auf 3.0 und höher nicht verfügbar, Node-Neustart oder Aus- und Einschalten einer Appliance

Summary: Der Zugriff auf die Webbenutzeroberfläche oder das Ausführen von PowerStore-CLI-Befehlen auf das System nach dem unterbrechungsfreien Upgrade auf 3.0 und höher, dem Neustart des Node oder dem Aus- und Einschalten einer Appliance ist nicht möglich. ...

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Symptoms

Die PowerStore Manager-Benutzeroberfläche oder -CLI (RestAPI und PSTCLI) ist nicht verfügbar und gibt möglicherweise die folgenden Fehler zurück:
  • Die PowerStore Manager-Benutzeroberfläche ist nach einem unterbrechungsfreien Upgrade, einem Node-Neustart oder einem Aus- und Einschalten der Appliance nicht zugänglich (Benutzer können sich nicht anmelden):
  • Der Versuch, sich anzumelden, schlägt mit dem folgenden Fehler fehl: „Service unavailable. Please retry in a few minutes. (0xE04040010004)" oder "503 Service Nicht verfügbar"
  • Wenn der Assistent für die Erstkonfiguration (ICW) den Serviceport verwendet, wird dem Benutzer möglicherweise die Meldung "Loading..." angezeigt. Im Schritt "Cluster Details", der eine Zeit lang fortgesetzt wird. Schließlich zeigt die Benutzeroberfläche möglicherweise "The required appliance was not found or Request timed out" an.

Aufgrund dieses Problems:
  • Für nicht konfigurierte Appliances
    • Es ist unmöglich, auf die PowerStore Manager-Anmeldeseite zuzugreifen oder sich bei der REST API anzumelden.
    • Connection Utility kann keine konfigurierten und nicht konfigurierten Appliances in einer solchen Umgebung anzeigen, da die Erkennungs-IP auf Appliances nicht vorhanden ist.
  • Für konfigurierte Appliances
    • Es ist unmöglich, auf die PowerStore Manager-Anmeldeseite zuzugreifen oder sich bei der REST API anzumelden.
    • Der Vorgang zum Hinzufügen einer Appliance ist nicht möglich.

Greifen Sie mithilfe von ssh auf das System zu, wenn ssh nicht aktiviert ist, verwenden Sie Serviceports, wie in PowerStore beschrieben: SSH- und PowerStore Manager-Zugriff über die Service-LAN-Ports.

Pstcli-Befehle können nicht ausgegeben werden.
[SVC:service@XXXXXXX-B user]$ pstcli -d  -u admin -session
Password (for host localhost):
The system was unable establish a secure connection to the storage server.
No IPv4 169.254/16 IP bonded on disc0:
 
[SVC:service@XXXXXXX-A user]$ ip a show | grep disc0 -A 3
11: disc0@eno1:  mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether aa:aa:aa:aa:aa:aa brd ff:ff:ff:ff:ff:ff
    inet6 fe80::18df:bcff:fe34:2b4a/64 scope link
       valid_lft forever preferred_lft forever
 
[SVC:service@XXXXXXX-B user]$ ip a show | grep disc0 -A 3
11: disc0@eno1:  mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether bb:bb:bb:bb:bb:bb brd ff:ff:ff:ff:ff:ff
    inet6 fe80::18df:bcff:fe34:2b4a/64 scope link
       valid_lft forever preferred_lft forever

 

 

Cause

Dieses Problem betrifft nur PowerStoreOS 3.0 und höher.
  • Während des Node-Startvorgangs nimmt der avahi-autoipd-Service zufällig eine IP-Adresse im Bereich 169.254.0.0/16 auf, testet, ob ein anderes Gerät diese IP mithilfe von Arping verwendet, und bindet sie dann an die Disc0-Schnittstelle.
  • Eine IP-Adresse der Disc0-Schnittstelle ist erforderlich, um den CONTROL Path HTTP-Stack zu laden.
  • Aufgrund einer unerwarteten ARP-Antwort von einem Netzwerkgerät in der Managementnetzwerkumgebung kann der avahi-autoipd-Service keine IP-Adresse abrufen, wodurch der HTTP-Stack des Kontrollpfads nicht geladen werden kann und der Zugriff auf WebUI und PSTCLI verloren gehen kann.

Resolution

Problemumgehung:
  • Identifizieren Sie das Gerät, das unerwartete ARP-Antworten an PowerStore sendet.
  • Das Problem kann behoben werden, indem der Switch oder das Gerät als Proxy-ARP im Verwaltungsnetzwerk angehalten wird. Führen Sie dies auf eine der folgenden Arten durch:
    • Aktualisieren Sie die Switch-Firmware auf die Version, die eine Lösung für das Problem enthält (relevant für Cisco-Switches, wie in https://quickview.cloudapps.cisco.com/quickview/bug/CSCul01316 beschrieben).
    • Wenn der "Proxy-ARP" auf dem Switch für den Zeroconf/Avahi-IP-Bereich von 169.254.0.0/16 aktiviert ist, wird empfohlen, diesen Bereich zu deaktivieren oder neu zu konfigurieren, um diesen Bereich auszuschließen, da er nicht für Proxy-ARP verwendet werden sollte.
      • Wenden Sie sich an den Netzwerkadministrator des Kunden, um zu überprüfen, ob die Deaktivierung dieser Einstellung keine Auswirkungen auf andere Netzwerkservices haben sollte.
      • Wenden Sie sich an den Netzwerkadministrator des Kunden, um diese Änderung am besten durchzuführen.
    • Isolieren Sie das Managementnetzwerk von PowerStore auf ein anderes Zugriffs- oder natives VLAN auf dem Switch.
  • Überprüfen Sie nach Abschluss aller oben genannten Schritte, ob disc0 über eine IPv4-Adresse im Bereich von 169.254.0.0/16 verfügt.
[SVC:service@XXXXXXX-A user]$ ip a show | grep disc0 -A 3
11: disc0@eno1:  mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether ea:44:78:0a:05:c0 brd ff:ff:ff:ff:ff:ff
    inet 169.254.60.18/16 brd 169.254.255.255 scope link disc0:mc
       valid_lft forever preferred_lft forever


[SVC:service@XXXXXXX-B user]$ ip a show | grep disc0 -A 3
11: disc0@eno1:  mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether 1a:df:bc:34:2b:4a brd ff:ff:ff:ff:ff:ff
    inet 169.254.64.234/16 brd 169.254.255.255 scope link disc0:mc
       valid_lft forever preferred_lft forever

 

 
     
    • Neustarten von ControlPath 
    [SVC:service@XXXXXXX-B user]$ svc_container_mgmt restart CP
    Waiting for container restart
    Container controlpath restart returned: 0
    Container controlpath is back up
    Waiting for stack to load
    Waiting for stack to load
    Waiting for stack to load
    Waiting for stack to load
    [SVC:service@XXXXXXX-B user]$
    

    Wenn Sie kein Netzwerkgerät identifizieren können, das unerwartete ARP-Antworten sendet, oder wenn Sie Unterstützung für dieses Problem benötigen, wenden Sie sich an den technischen Support oder Ihren autorisierten Servicemitarbeiter und geben Sie diese Artikel-ID der Dell Knowledge Base an.

    Lösung:
    Dieses Problem wurde in PowerStoreOS v3.6.0.0
    behoben (siehe MDT-498676, der in der Versionshinweise für diese Betriebssystemversion aufgeführt ist.)

    Affected Products

    PowerStore, PowerStore 1000X, PowerStore 1000T, PowerStore 1200T, PowerStore 3000X, PowerStore 3000T, PowerStore 3200T, PowerStore 5000X, PowerStore 5000T, PowerStore 500T

    Products

    PowerStore 5200T, PowerStore 7000X, PowerStore 7000T, PowerStore 9000X, PowerStore 9000T, PowerStore 9200T
    Article Properties
    Article Number: 000211171
    Article Type: Solution
    Last Modified: 23 Oct 2023
    Version:  7
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