Avamar: Desempenho do Windows Server: Backup lento do file system em servidores com unidades PGP

Summary: Este artigo da Base de conhecimento discute problemas de desempenho lento de backup causados por SIDs (identificadores de segurança) do Windows no Avamar, resultando em backups atrasados devido à coleta de perfil de usuário. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

O desempenho de backup do Avamar é lento.

Exemplo: 

Backed-up 6.659 MB in 105.79 minutes: 3.8 MB/hour (1 files/hour)

Cause

Nos logs de backup com depuração ativada, o backup inicia e termina rapidamente, conforme mostrado abaixo.

O início do trabalho de backup começa da seguinte maneira:

2017-05-25 04:33:52 avtar Info : Logging to C:\Program Files\avs\var\Test05232017.log xxxxxxxxxxxxxxxxx

O trabalho de backup é feito rapidamente, conforme mostrado aqui:

2017/05/25-02:34:17.84500 [avtar] creating .system_info directory
2017-05-25 04:34:17 avtar Info : Backup complete, wrapping-up session with Server

A demora foi na criação dos perfis de usuário ".system_info/userinfo.xml" Como começa a ler os perfis:

2017-05-25 04:34:18 avtar Info : Reading 37 user profiles

Mais de duas horas depois, a enumeração dos perfis de usuário foi concluída:

2017-05-25 06:50:34 avtar Info : Done reading user profiles

O backup foi concluído meio segundo depois.

2017-05-25 06:50:35 avtar Info : Backup #10 timestamp 2017-05-25 06:50:34, 3 files, 3 folders, 4.578 KB (3 files, 1.576 KB, 34.43% new)
2017/05/25-04:50:35.04299 [avtar] backup expire prectime=131431854349654640
2017-05-25 06:50:35 avtar Info : Label "test w/new flags", scheduled to expire after 06/29/17 (2017-06-29 04:50:34 UTC)
2017-05-25 06:50:35 avtar Info : Backed-up 4.578 KB in 136.72 minutes: 2.0 KB/hour (1 files/hour)


O problema foi isolado em alguns SIDs, como SID "S-1-5-21-1761170581-294597109-3035037286-64925452" que tinha a entrada de nome de usuário correspondente ausente. O processo da Avtar travou no processamento desses SIDs, causando esse atraso.

Resolution

Como solução temporária, crie um arquivo de avtar.cmd no diretório C:\Program Files\var ou em qualquer pasta em que o software client Avamar Windows esteja instalado. Em seguida, adicione o seguinte indicador e salve o arquivo:

--x05=65536

 

Esse indicador desabilita a coleta de perfil de usuário durante o processo de backup. Esse indicador tem um impacto significativo no desempenho. A longo prazo, verifique as confianças de domínio do Active Directory no ambiente e limpe as contas de domínio que têm entradas de SID inconsistentes. Para fazer isso, obtenha mais detalhes sobre esses SIDs usando o procedimento abaixo.

1. Abra o Editor do Registro digitando o seguinte comando na barra de pesquisa do Windows:

regedit

2. Vá para o caminho abaixo:

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList

Todos os SIDs estão listados aqui, e o "ProfileImagePath" é sobre o nome de cada SID.
3. Usar o aplicativo de terceiros "PsGetSid.exe" para listar o nome na linha de comando.

Exemplo:

PsGetsid S-1-5-21-854245398-1973579041-362214817-1745107


PsGetSid.exe está disponível em: https://learn.microsoft.com/en-us/sysinternals/downloads/psgetsid (Link externo)

Depois que as contas de usuário problemáticas forem removidas, exclua-as do registro usando regedit.exe. O indicador avtar não será mais necessário depois que a limpeza for concluída.

--x05=65536

Affected Products

Avamar, Avamar Client for Windows
Article Properties
Article Number: 000053881
Article Type: Solution
Last Modified: 24 Sept 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.