ECS: Dial Home – Ref_ID: BtreeChunkLevelGC – Symptomcode: 1321

Summary: Dies ist ein in ECS 3.3 eingeführtes Dial-Home, um Wachsam.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Ein ECS-System hat Dialed Home mit der folgenden Warnmeldung ausgeführt. 

<?xml version="1.0" encoding="UTF-8"?>
<ConnectHome SchemaVersion="1.0.8"
    xsi:schemaLocation="/opt/connectemc/schema/ema_ConnectHome108.xsd" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <TransType>10</TransType>
    <TransTypeDesc>EventXML</TransTypeDesc>
    <TransID>0</TransID>
    <Node Status="Unknown" State="Unknown" ID="psnt1">
        <Identifier>
            <DeviceState>1</DeviceState>
            <DeviceStatus>1</DeviceStatus>
            <ClarifyID>psnt1</ClarifyID>
            <SiteName>UNKNOWN</SiteName>
            <Vendor>EMC</Vendor>
            <DeviceType>ElasticCloudStorageApp</DeviceType>
            <Model>ElasticCloudStorage</Model>
            <SerialNumber>psnt1</SerialNumber>
            <WWN>ECSQE00077</WWN>
            <Platform>platform</Platform>
            <OS>SLES</OS>
            <OS_VER>12.3</OS_VER>
            <UcodeVer>3.3.0.0-4352.834410f</UcodeVer>
            <EmbedLevel>2</EmbedLevel>
            <InternalMaxSize>512800</InternalMaxSize>
            <Comment>Object Alert</Comment>
        </Identifier>
        <Connection>
            <ConnectType>ESRS</ConnectType>
            <IPName>orem-maize.ecs.lab.emc.com</IPName>
            <ConnectNum>169.254.197.3</ConnectNum>
            <Port>22</Port>
        </Connection>
        <HeartBeat>
            <HBStatus></HBStatus>
            <HBState></HBState>
        </HeartBeat>
        <InternalData>
            <FileList/>
            <EventList>
                <Event>
                    <SymptomCode>1321</SymptomCode>
                    <Category>Configuration</Category>
                    <Severity>Warning</Severity>
                    <Status>Unknown</Status>
                    <Component>Object</Component>
                    <ComponentID></ComponentID>
                    <SubComponent>BTREE Chunk GC</SubComponent>
                    <SubComponentID></SubComponentID>
                    <CallHome>true</CallHome>
                    <FirstTime>2019-01-29T20:09:07.861Z</FirstTime>
                    <LastTime>2019-01-29T20:09:07.861Z</LastTime>
                    <Count>0</Count>
                    <EventData><![CDATA[]]></EventData>
                    <Description><![CDATA[System metadata garbage collection throughput is too slow to catch up with garbage detection. Please involve ECS engineering.  [Ref_ID : BtreeChunkLevelGC]]]></Description>
                </Event>
            </EventList>
        </InternalData>
        <ExternalFiles/>
    </Node>
</ConnectHome>

Cause

BTREE GC arbeitet in der Phase der Blockrückgewinnung langsam. Diese Warnmeldung wird erzeugt, wenn mehr als 1 TB vollständig veralteter Objekte vorhanden sind und die Differenz zwischen der Erfassungsrate für veraltete Objekte und der Rückgewinnungsrate von veralteten Blöcken mehr als 100 GB beträgt. Die Warnmeldung wird gesendet, wenn sich das System 7 Tage lang in diesem Zustand befunden hat.

Resolution

  1. Stellen Sie über eine PuTTY-Sitzung eine Verbindung zu einem der Nodes im Cluster her.
  2. Überprüfen Sie den aktuellen Sensorstatus.
Befehl:
svc_rest_cmd -i `hostname -i` /vdc/sensor/status/BtreeChunkLevelGC
# svc_rest_cmd -i `hostname -i` /vdc/sensor/status/BtreeChunkLevelGC
svc_rest_cmd 1.0.10

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<SensorStatusList>
  <SensorId>BtreeChunkLevelGC</SensorId>
  <ListSensorStatus>
    <SensorStatusRestRep>
      <ContextId>Btree Chunk Level GC</ContextId>
      <CurrentState>OK</CurrentState>
      <NodeId>1f4368c3-37cd-467f-9efc-289264806ea0</NodeId>
      <PreviousState>OK</PreviousState>
      <Time>1551118064264</Time>
    </SensorStatusRestRep>
  </ListSensorStatus>
  1. Suchen Sie nach <CurrentState>. Wenn OK eingestellt ist, ist der Fehler nicht aktiv und es handelt sich wahrscheinlich um eine falsche Warnmeldung. Ignorieren Sie die Warnmeldung, aber wenn sie innerhalb der nächsten Woche erneut ausgelöst wird, öffnen Sie einen Service-Request beim technischen Support.

Affected Products

ConnectEMC, ECS Appliance
Article Properties
Article Number: 000038616
Article Type: Solution
Last Modified: 17 Dec 2025
Version:  8
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.