Data Protection Advisor: DataDomain data collection Requests fail with Either host [nodename] is down or invalid credentials has been provided
Summary: This article provides information when DataDomain data collection Requests fail with Either host [nodename] is down or invalid credentials has been provided.
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This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Some or all DPA DataDomain data collection Requests (example: config, status, perf, sshstatus) fail. The Request History and the Agent log contain the following error:
Either host [nodename] is down or invalid credentials has been provided.
Either host [nodename] is down or invalid credentials has been provided.
Cause
The product is functioning as designed.
This error can be generated in several scenarios.
1) The DataDomain is somehow unreachable or down.
2) The Request is configured with the incorrect DataDomain community string that does not have proper privileges. This is either a DPA Request misconfiguration in the Credentials used by the Request or a configuration problem on the DataDomain.
3) The Request is reaching the time out value before completion. The default time out for the DPA Request is not sufficient for the response time of the DD to the commands being issued either through SNMP or SSH. This is most common with SNMP.
This error can be generated in several scenarios.
1) The DataDomain is somehow unreachable or down.
2) The Request is configured with the incorrect DataDomain community string that does not have proper privileges. This is either a DPA Request misconfiguration in the Credentials used by the Request or a configuration problem on the DataDomain.
3) The Request is reaching the time out value before completion. The default time out for the DPA Request is not sufficient for the response time of the DD to the commands being issued either through SNMP or SSH. This is most common with SNMP.
Resolution
The product is functioning as designed.
Depending on the cause of the issue the resolution can be different. From the 3 possible causes listed in the Cause section, the below resolutions are:
1) This is likely an environmental problem. This may involved the server (example, firewall), the network, or the DataDomain itself. This requires investigation by the Administrators of the environment.
2) Ensure the correct DataDomain community string with proper read privileges is configured on the DataDomain and configured to be used for the DPA Request.
3) Adjust the DPA Request time out higher to cover the response time for the Request in a worst case scenario (say when the DataDomain is busiest). This may require some trial and error. Normally it is advised to increase the time out in increments (for example doubling it) until the time outs cease or are reduced to an acceptable level.
Note: Some Requests, such as SNMP Requests should not have their timeouts adjusted beyond 2100.
Note: In some environments due to DataDomain performance issues there may still be periodic time outs with some DataDomain Requests. If the time outs are infrequent and the retry succeeds in the next couple of Request attempts, then likely Reports will not be noticeably affected. This may not be avoidable in some very busy DataDomain environments.
Please contact Dell EMC Technical Support for further details or information.
Depending on the cause of the issue the resolution can be different. From the 3 possible causes listed in the Cause section, the below resolutions are:
1) This is likely an environmental problem. This may involved the server (example, firewall), the network, or the DataDomain itself. This requires investigation by the Administrators of the environment.
2) Ensure the correct DataDomain community string with proper read privileges is configured on the DataDomain and configured to be used for the DPA Request.
3) Adjust the DPA Request time out higher to cover the response time for the Request in a worst case scenario (say when the DataDomain is busiest). This may require some trial and error. Normally it is advised to increase the time out in increments (for example doubling it) until the time outs cease or are reduced to an acceptable level.
Note: Some Requests, such as SNMP Requests should not have their timeouts adjusted beyond 2100.
Note: In some environments due to DataDomain performance issues there may still be periodic time outs with some DataDomain Requests. If the time outs are infrequent and the retry succeeds in the next couple of Request attempts, then likely Reports will not be noticeably affected. This may not be avoidable in some very busy DataDomain environments.
Please contact Dell EMC Technical Support for further details or information.
Affected Products
Data Protection AdvisorArticle Properties
Article Number: 000045456
Article Type: Solution
Last Modified: 23 Sep 2024
Version: 4
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