Unisphere for vmax stop collecting performance data

Summary: Storstpd is unable to .zip files due to daemon options.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Unisphere is not collecting performance data, all fields is showing as N/A.

From the storstpd.log, the storstpd daemon is failing to .zip files:

[2956 AuditLogger] Sep-25 7:00:01.734 : [auditLogger()] Id: 280 SID: 0001987XXXXX Audit log generation: E:\Program Files\EMC\SYMAPI\stp\spa\DMF_10.80.xx.xx\20170925_1400_0001987XXXXX.xml <Error> [2956 StatCollector] Sep-25 7:00:01.969 : [runZipCommand()] TID: 4700 SID: 0001987XXXXX Zip Command check result 700006011: [PDS/File] File or Directory doesn't exist [2956 StatCollector] Sep-25 7:00:01.969 : [runZipCommand()] TID: 4700 SID: 0001987XXXXX no Zip command is available, bypassing zip execution.

 

Cause

The errors are misleading in this situation, the cause of issue is due to following options being enabled in the daemon options file:

storstpd:DMN_RUN_RTC  = enable
storstpd:dmn_collect_for_cs = enabled

If daemon_options file has storstpd:DMN_COLLECT_FOR_CS=enabled, then that node's storstpd can only be used for collecting DCF files to disk for a third part application, storstpd cannot also be used to collect DCF files for Unisphere for VMAX.
So when storstpd:DMN_COLLECT_FOR_CS=enabled then there are no DCF files sent over the network to Unisphere for VMAX.

 

Resolution

Comment out the following options in the daemon options file:

#storstpd:DMN_RUN_RTC  = enable
#storstpd:dmn_collect_for_cs = enabled

 

Affected Products

Unisphere for VMAX

Products

Solutions Enabler, Unisphere for VMAX
Article Properties
Article Number: 000050012
Article Type: Solution
Last Modified: 23 Jan 2026
Version:  4
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