Dell EMC Unity: Cannot expand storage pool; not enough drives (customer correctable)
Summary: Unity: Cannot expand storage pool; not enough drives (customer correctable)
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Symptoms
User added 3 drives to array. He now has a total of 4 drives available. (In my customer's case; these quantities may vary depending on your customer's RAID type).
User has added new drives to Unity array and is attempting to expand storage pool. He cannot since it says that he does not have enough drives available.
User has added new drives to Unity array and is attempting to expand storage pool. He cannot since it says that he does not have enough drives available.
Cause
Unity provides for two storage pool architectures; Dynamic Pools or Traditional Pools.
Dynamic Pools can be expanded with as little as one or two drives at a time.
However, to expand Traditional Pools, you must have a minimum number of drives based on the RAID type in use.
RAID 5 5
RAID 6 6
RAID 1/0 2
Dynamic Pools can be expanded with as little as one or two drives at a time.
However, to expand Traditional Pools, you must have a minimum number of drives based on the RAID type in use.
RAID 5 5
RAID 6 6
RAID 1/0 2
Resolution
User was using Traditional Pools and therefore did not have minimum number of drives to expand (customer in my case was using RAID 5).
To determine if customer is using Traditional or Dynamic Pools....
1.In Unisphere, in the upper right, click on the Settings button (looks like a gear).
2.In the Settings window, click on the Storage Configuration tab on the left.
3.If you're using OE code 4.2, you should only have the Drives sub menu under the Storage Configuration tab. It will list how many drives you have of each type/size and on the far right, it will show how many are configured as part of a dynamic pool and how many are configured as part of a traditional pool.

To determine if customer is using Traditional or Dynamic Pools....
1.In Unisphere, in the upper right, click on the Settings button (looks like a gear).
2.In the Settings window, click on the Storage Configuration tab on the left.
3.If you're using OE code 4.2, you should only have the Drives sub menu under the Storage Configuration tab. It will list how many drives you have of each type/size and on the far right, it will show how many are configured as part of a dynamic pool and how many are configured as part of a traditional pool.

Additional Information
For more info regarding Dynamic Pools vs. Traditional Pools please see Dell EMC Unity: Dynamic Pools Overview.
Affected Products
Dell EMC Unity FamilyProducts
Dell EMC Unity FamilyArticle Properties
Article Number: 000052728
Article Type: Solution
Last Modified: 12 Dec 2025
Version: 4
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