vProxy:すべてのVMが正常に完了したときに、VMwareポリシーに「failed」と表示される

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

VMware保護ポリシーによって保護されていた仮想マシンがvCenterインベントリから削除されたか、削除されました。  

NetWorker VMware Protection統合は、vProxyアプライアンスを使用して構成されています。  NMC(NetWorker管理コンソール)の[モニタリング]タブに、VMwareポリシーのバックアップ ワークフローが失敗ステータスで表示され、仮想マシンが失敗と表示されます。  

 
kA2f1000000RMnOCAW_3_0
 
Backup detailsの[Action Message]セクションの[Final Summary]セクションには失敗したバックアップが表示されますが、[Backup details]の[Failed]セクションには仮想マシンが表示されません。  
 
kA2f1000000RMnOCAW_3_1

showアクション ログとワークフロー ログには、選択した仮想マシンが見つからなかったことを示す詳細が表示されます。
 
MM/DD/YYYY HH: MM: SS Action backup vmware-vproxy 'backup' has initialized as 'vproxysave job' with job id 2149388
......
MM/DD/YYYY HH: MM: SS UUIDが「xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx」の選択したVM作業アイテムがvCenterで見つかりません。作業アイテムはスキップされます。
MM/DD/YYYY HH: MM: SS UUIDが「xxxxxxxx-xxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx」の選択したVM作業アイテムがvCenterで見つかりません。作業アイテムはスキップされます
...
MM/DD/YYYY HH:MM:SS VMの最終サマリー: 
MM/DD/YYYY HH:MM:SS 0 バックアップのキャンセル
MM/DD/YYYY HH:MM:SS 2 失敗したバックアップ
MM/DD/YYYY HH:MM:SS 2 バックアップの成功
MM/DD/YYYY HH:MM:SS 0 バックアップの待機中
MM/DD/YYYY HH:MM:SS 0 バックアップの実行中
MM/DD/YYYY HH:MM:SS 2 セーブセットが次のアクションに出力されます
MM/DD/YYYY HH:MM:SSアクションが失敗で終了しました。
MM/DD/YYYY HH: MM: SS アクション backup vmware-vproxy 'backup' (ジョブ ID 2149388) がステータス「failed」で終了しています。終了コード 1

Cause

VMware保護ポリシーによって保護されていた仮想マシンがvCenterインベントリーから削除されました。  NetWorker nsrdbデータベースはUUIDで仮想マシンを格納し、バックアップ ワークフローの開始時に仮想マシンのルックアップを実行します。

Resolution

この動作は、仮想マシンがvCenterインベントリーから削除され、後でvCenterインベントリーに再度追加された場合の動作仕様によるものです。  仮想マシンがインベントリーから削除された場合は、vCenterインベントリーに再度追加されると、引き続きVMware保護グループの一部になります

仮想マシンをVMware保護グループから削除する前にvCenter環境から仮想マシンを削除した場合は、nsrpolicyコマンド ライン ユーティリティーを使用してvCenterインベントリーから削除できます

nsrpolicy group update vmware -g [GROUP_NAME] -O "[UUID]"

出力例:
C:\>nsrpolicy group update vmware -g Gold-Vmware -O "503de6ca-b3e5-xxxx-xxxx-xxxxxxxxxxxx"
133584:nsrpolicy: Group 'Gold-Vmware' was successfully updated


 
Article Properties
Article Number: 000052939
Article Type: Solution
Last Modified: 20 Nov 2020
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.