PowerScale: WebUI non disponibile, ricezione dell'errore 503 o 404

Summary: Dopo l'aggiornamento o il riavvio di OneFS, un cluster talvolta mostra l'interfaccia di amministrazione web (WebUI) come non disponibile con l'errore 503, l'errore 404 o l'errore 400.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Dopo un aggiornamento o un riavvio di OneFS, l'interfaccia di amministrazione web (WebUI) non è disponibile. Si riceve un errore 503, 404 o anche 400.

Cause

I servizi che forniscono il processo in background e in primo piano per produrre la WebUI non si avviano correttamente.

Resolution

Eseguire i seguenti comandi per arrestare il sistema, quindi riavviare il processo.

Queste righe disabilitano tutti i servizi che forniscono l'interfaccia utente web.
isi services -a apache2 disable

isi services -a isi_webui disable

isi services -a isi_papi_d disable

isi services -a isi_stats_d disable

isi services -a isi_stats_hist_d disable
Verificare che i servizi siano stati arrestati prima di riabilitarli.
ps auwx | grep httpd | grep -v grep

isi_for_array ps auwx | grep webui | grep -v grep

isi_for_array ps auwx | grep isi_papi_d | grep -v grep

isi_for_array ps auwx | grep isi_stats_d | grep -v grep

isi_for_array ps auwx | grep isi_stats_hist_d | grep -v grep
Quando si tenta di avviare l'interfaccia utente web su un nodo con un .pid file, il sistema interpreta l'esistenza di questi file nel senso che l'interfaccia utente web è già in esecuzione. L'arresto dei processi e la loro ripartenza non funzionerebbero se un .pid Il file è presente in uno qualsiasi dei nodi.

Eseguire i seguenti comandi per rimuovere qualsiasi .pid Potrebbero essere presenti dei file che impediscono l'avvio del servizio web.
isi_for_array rm /usr/local/www/webkit/appserver.pid

isi_for_array rm /var/apache2/run/httpd.pid

isi_for_array rm /var/apache2/run/webui_httpd.pid
Una volta rimossi eventuali .pid eventualmente presenti, eseguire i seguenti comandi per ripristinare tutti i servizi WebUI.
isi services -a apache2 enable

isi services -a isi_webui enable

isi services -a isi_papi_d enable

isi services -a isi_stats_d enable

isi services -a isi_stats_hist_d enable
Testare l'interfaccia WebUI e verificare se il problema è stato risolto.
 
Nota: OneFS 9.4 e versioni successive includono la possibilità di utilizzare il nome di dominio completo (FQDN) SmartConnect nell'interfaccia utente web del cluster quando le sessioni si spostano tra i nodi.

Affected Products

PowerScale OneFS
Article Properties
Article Number: 000053026
Article Type: Solution
Last Modified: 17 Sep 2025
Version:  7
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.