Symptoms
Users may be unable to perform any actions on alerts that are shown in reports like
All Alerts,
Unacknowledged Alerts and others. Actions that do not work include '
Acknowledge', '
Assign', '
Force Close' and '
Take Ownership'. Users may also be unable to acknowledge compliance breaches.
When selecting any of the available actions, any of the following error messages may be shown briefly in the SRM GUI:
java.net.UnknownHostException: (FQDN)
at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:184)
at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)
at java.net.Socket.connect(Socket.java:589)
OR:
java.net.NoRouteToHostException: No route to host
at java.net.PlainSocketImpl.socketConnect(Native Method)
at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:350)
at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:206)
at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:188)
at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)
at java.net.Socket.connect(Socket.java:589)
OR:
java.net.ConnectException: Connection refused (Connection refused)
at java.net.PlainSocketImpl.socketConnect(Native Method)
at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:350)
at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:206)
at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:188)
at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)
at java.net.Socket.connect(Socket.java:589)
Cause
Alert actions work by running scripts on the Frontend host. In some circumstances, a configuration file on the Frontend host may have an incorrect setting for the Primary Backend host and this prevents the scripts on the Frontend host from connecting to the Primary Backend host and perform the required actions on the event or compliance database.
Resolution
Locate the following configuration file on the Frontend host:
/opt/APG/Custom/WebApps-Resources/Default/actions/event-mgmt/linux/conf
\Program Files\APG\Custom\WebApps-Resources\Default\actions\event-mgmt\windows\conf.cmd
Edit the following entry and ensure that it contains the correct IP address or FQDN of the Primary Backend host:
PRIMARYBACKEND=<IP or FQDN>
set PRIMARYBACKEND=<IP or FQDN>
Save the
conf file and re-try the alert actions. No service restarts are necessary. The configuration file is read every time an action script is invoked.
Important: Care must be taken so that the edited file
does not contain any line break characters (especially the invisible 'Carriage Return' character) after the IP or FQDN as this character would be added to the
PRIMARYBACKEND variable and break the host name resolution, resulting in UnknownHostException error.