VNX: Czyszczenie replikacji w przypadku uszkodzenia/nieaktywności głównych punktów kontrolnych replikacji (możliwość naprawienia przez użytkownika)

Summary: Czyszczenie replikacji w przypadku uszkodzenia/nieaktywności głównych punktów kontrolnych replikacji (możliwość naprawienia przez użytkownika)

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Uszkodzenie głównych punktów kontrolnych (częstym powodem jest to, że jednostki LUN backendu mają nienaprawialne z powodu awarii dysku)
 
[nasadmin@CS0 ~]$ server_mount ALL | grep unmount
root_rep_ckpt_28_242474_1 on /root_rep_ckpt_28_242474_1 ckpt,perm,ro,<unmounted>
root_rep_ckpt_28_242474_2 on /root_rep_ckpt_28_242474_2 ckpt,perm,ro,<unmounted>
root_rep_ckpt_27_242517_1 on /root_rep_ckpt_27_242517_1 ckpt,perm,ro,<unmounted>
root_rep_ckpt_27_242517_2 on /root_rep_ckpt_27_242517_2 ckpt,perm,ro,<unmounted>

W powyższych danych wyjściowych widoczne są tylko punkty kontrolne katalogu głównego, co oznacza, że główny system plików jest dobry. Dzieje się tak zwykle, jeśli savvol jest zbudowany na innej puli pamięci, która uległa uszkodzeniu, a powiązany system plików jest bezpieczny.
[nasadmin@CS0 ~]$ nas_replicate -l
Name                      Type       Local Mover               Interconnect         Celerra      Status
rep_fs1                filesystem server_2                  -->Replication       Remote_CS  Critical 8865448248:The replication session encountered an error that halted progress.
rep_fs2                filesystem server_2                  -->Replication       Remote_CS  OK
rep_fs3                filesystem server_2                  -->Replication       Remote_CS  Critical 8865448248:The replication session encountered an error that halted progress.
Powyższe dane wyjściowe będą odzwierciedlać błąd widoczny w błędach krytycznych 2 replikacji (który odpowiada 2 zestawom stanu odmontowania głównego punktu kontrolnego widocznym w server_mount danych wyjściowych)

Cause

Jeśli moduł przenoszenia danych ulegnie awarii, w większości przypadków jest to spowodowane uszkodzeniem spowodowanym przez dyski, a VNX oznaczy system plików jako uszkodzony. Główne punkty kontrolne również zostaną odmontowane.

Resolution

Uwaga: Najpierw należy rozwiązać problemy z zapleczem, na przykład jeśli jakieś dyski wymagają wymiany, to muszą być one pierwsze. 

Aby usunąć replikacje, których dotyczy problem:

Jeśli sesje zostaną usunięte bezpośrednio, zadanie usuwania może zostać zawieszone. Ponieważ usunięcie spróbuje zaktualizować główne punkty kontrolne, a aktualizacja zawiesi się, ponieważ jest uszkodzona. Zapoznaj się z sekcją uwag, aby rozwiązać ten problem. Ta procedura ma na celu naprawienie w odpowiedniej kolejności i należy ją wykonać ze stacji kontrolnej za pomocą wiersza polecenia.

1) Zaloguj się do stacji kontrolnej jako nasadmin.

2) Zidentyfikuj nazwę sesji replikacji, postępując zgodnie z poniższym przykładem:
a) Find the full name of root checkpoints by:
[nasadmin@CS0 ~]$ server_mount ALL | grep unmount
root_rep_ckpt_28_242474_1 on /root_rep_ckpt_28_242474_1 ckpt,perm,ro,<unmounted>
root_rep_ckpt_28_242474_2 on /root_rep_ckpt_28_242474_2 ckpt,perm,ro,<unmounted>
b) For each checkpoint, issue the following command and note the file system name
[nasadmin@CS0 ~]$ /nas/sbin/rootnas_fs -info root_rep_ckpt_28_242474_1 | grep checkpt_of
checkpt_of= fs1 Mon Jun 15 16:51:54 EDT 2015

Repeat above as every FS will have 2 root checkpoints per replication session, so good to get all FS names first before proceeding to next step

2) Zidentyfikuj punkty kontrolne replikacji i usuń je, postępując zgodnie z poniższym przykładem
 
a) Identify the file system name from the replications failing with critical errors by :
nas_replicate -list

Example: 
$ nas_replicate -i jsq-stx-mq
ID                             = 156_APM001_01F4_137_APM002_01F4
Name                           = rep_fs1
Source Status                  = Critical 8865448248: The replication session encountered an error that halted progres                                                                                          s.
Network Status                 = OK
Destination Status             = OK
Last Sync Time                 = Wed Jul 13 14:35:15 EDT 2016
Type                           = filesystem
Celerra Network Server         = CS01
Dart Interconnect              = Replication
Peer Dart Interconnect         = Replication
Replication Role               = source  <== note the role 
Source Filesystem              = fs1 <== this is the fs name if the role is source
Source Data Mover              = server_2
Source Interface               = 10.x.x.x
Source Control Port            = 0
Source Current Data Port       = 0
Destination Filesystem         = fs1-DR <== this is the fs name if the role is destination
Destination Data Mover         = server_2
Destination Interface          = 10.x.x.x
...

Match this name from names identified in step 2 to ensure they are same.
b) Check the replication checkpoint status by : fs_ckpt <fs_name> -list -all

Example: 
$ fs_ckpt fs1 -list -all
id    ckpt_name                creation_time           inuse fullmark   total_savvol_used  ckpt_usage_on_savvol
32    root_rep_ckpt_28_242474_ 06/15/2015-16:51:54-EDT   y   90%        INACTIVE           N/A
33    root_rep_ckpt_28_242474_ 06/15/2015-16:51:56-EDT   y   90%        INACTIVE           N/A
34    fs1_ckpt1                          06/17/2015-16:51:56-EDT   y   90%        INACTIVE           N/A
Info 26306752329: The value of ckpt_usage_on_savvol for read-only checkpoints may not be consistent with the total_savvol_used.

id    wckpt_name               inuse fullmark total_savvol_used  base  ckpt_usage_on_savvol

INACTIVE indicates, this is corrupted.
c) If the "inuse" value is "y", delete the root checkpoints using the following command:  /nas/sbin/rootnas_fs -delete id=<root_ckpt_id> -o umount=yes -ALLOW_REP_INT_CKPT_OP 
Rarely, root checkpoint may have, inuse" value as "n", then,  /nas/sbin/rootnas_fs -delete id=<root_ckpt_id> -ALLOW_REP_INT_CKPT_OP 

Example:
[nasadmin@CS0 ~]$ /nas/sbin/rootnas_fs -delete id=32  -o umount=yes -ALLOW_REP_INT_CKPT_OP 
id        = 32
name      = root_rep_ckpt_28_242474_1
acl       = 0
in_use    = True
type      = ckpt
worm      = off
..

d) Repeat above step and delete all the root checkpoints 
e) For non root checkpoints, delete using same command with out the last arument (Example: /nas/sbin/rootnas_fs -delete id=34 -o umount=yes)
3) Usuń sesję replikacji, używając następującej składni:
For the "source" replication role : nas_replicate -delete <replication_session_name> -mode source -background
For the "destination" replication role : nas_replicate -delete <replication_session_name> -mode destination -background

Above command will give a task number, which can be used to view the status, by "nas_task -i <task_number>

4) Usuń replikację również po stronie zdalnej, wykonując czynności opisane powyżej w kroku 3.
 [ "nas_replicate -delete <session_name> -mode <mode> -background" ] 
Jeśli wszystkie powyższe kroki zostaną wykonane, operacja usuwania replikacji zostanie zakończona. Nowa replikacja może być ponownie skonfigurowana za pomocą Unisphere lub wiersza polecenia.

Jeśli którykolwiek z powyższych kroków nie powiedzie się, skontaktuj się z działem pomocy technicznej firmy Dell EMC .  Podaj ten identyfikator artykułu z bazy wiedzy.

Additional Information

W przypadku bezpośredniej próby usunięcia sesji w Unisphere lub za pomocą polecenia "nas_replicate -delete", zadanie usuwania może zostać zawieszone. W większości przypadków można to naprawić bez konieczności ponownego uruchamiania modułu przenoszenia danych.

1) Zidentyfikuj zadanie za pomocą:
nas_task -list | grep -i run

2) Szczegółowe informacje (w szczególności nazwę podmiotu przenoszącego dane) można znaleźć, poprzez:
nas_task -info <task_number>

3) Przerwij zadanie poprzez:
nas_task -abort <task_numer> -mover <data_mover_name>

Powyżej należy również usunąć sesję replikacji i główne punkty kontrolne. Wszystkie punkty kontrolne użytkownika należy usunąć ręcznie.

Affected Products

vVNX
Article Properties
Article Number: 000056557
Article Type: Solution
Last Modified: 29 Jul 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.