Isilon Search LDAP configuration cannot be saved

Summary: When attempting to edit or save an LDAP configuration, it fails with an error.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

When there are multiple LDAP connections attempting to edit and save the configuration of any LDAP connection in the Isilon search web interface fails with the following error:

Failed to establish connection.Either the server address is invalid or the connection parameters are not correct. Check them and try again

Attempting to delete the LDAP connection also fails with the same error.

 

Any user or group added to server or index roles using this connection also cannot be deleted and report:

failed to delete user

 

Cause

When LDAP configuration is saved all connections are validated, and if there are multiple connections that cannot be validated none can be updated.

 

Resolution

This issue is to be resolved in Isilon Search versions higher than 2.0.0.2024. Isilon Search software, service pack, and patches can be downloaded from Support.

 

If there is no version available with a fix for this issue, a workaround can be implemented with the assistance of support. Open a support case and reference this article.

 

Affected Products

Isilon Search
Article Properties
Article Number: 000057272
Article Type: Solution
Last Modified: 29 Aug 2024
Version:  3
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