PowerStore: Unencrypted Clusters – Drive Related Considerations
Summary: Customers may purchase PowerStore Appliances where data encryption is disabled due to strict government regulations. Adding a previously used drive to an unencrypted appliance can impose a risk to the system, potentially causing Partial Data Inconsistency. ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Customers may purchase from Dell EMC, PowerStore Appliances where data encryption is disabled due to strict government regulations.
If a drive that was previously used is added to the unencrypted appliance, the appliance will identify the drive and allow it to be added to the system.
Such a drive will impose a risk to the system, in the event of a catastrophic event and may result in Partial Data Inconsistency.
The following limitations apply:
If a drive that was previously used is added to the unencrypted appliance, the appliance will identify the drive and allow it to be added to the system.
Such a drive will impose a risk to the system, in the event of a catastrophic event and may result in Partial Data Inconsistency.
The following limitations apply:
- When Scaling-Out or replacing a defective drive, only use hardware ordered from DellEMC (arrived directly from Dell manufacturing).
- Do not reuse hardware originating from another Appliance.
Query Encryption Configuration
To query your cluster’s encryption configuration, use either: - The PowerStore Manager (Settings --> Encryption)
- The RestAPI
Solution
The issue is resolved in release 1.0.1.0.5.002 and later.
Cause
- Customers may purchase from Dell EMC, PowerStore Appliances where data encryption is disabled due to strict government regulations.
- When Scaling-Out or replacing a defective drive, only use hardware ordered from DellEMC (arrived directly from Dell manufacturing).
- Do not reuse hardware originating from another Appliance.
Resolution
The issue is resolved in release 1.0.1.0.5.002 and later.
Affected Products
PowerStoreArticle Properties
Article Number: 000123157
Article Type: Solution
Last Modified: 13 Jun 2025
Version: 6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.