PowerStore: "Import failed while switching path on host." Error: 0XE0310020044
Summary: This article details the cause and resolution to Error: 0XE0310020044; "Import failed while switching path on host."
Symptoms
A PowerStore Import fails when the Linux Host /etc/multipath.conf file has been incorrectly modified so that the "blacklist" contents are not properly parsed in the PowerStore/Equallogic plug-in. In this case, the ability to switch between paths to the Import volume has been degraded, preventing the Import from succeeding.
Cause
When configuring the Linux Host for PowerStore Import, and installing the PowerStore plug-in (ImportKit), administrators may decide to edit the multipath.conf file manually. Incorrect editing of this file can result in Import failures and must be corrected. This article provides an example of how the blacklist section of the multipath.conf should appear. Administrators should leave the default blacklist settings in place, unless they have specific requirements that they must follow.
Resolution
1. Verify, and edit if necessary, the "blacklist" section of your /etc/multipath.conf file on the Linux Host. The "blacklist" section should look similar to the following example, with brackets beginning and ending on separate lines, as shown below:
blacklist {
wwid 36000d31001531000000000000000000b
wwid 368ccf098003bb14a19d5f7cafac75739
wwid 36000d310015310000000000000000009
wwid 368ccf098008dc3d1e2b1020b7af8e83e
wwid 368ccf09800872b5b2084e062ef82e3e4
wwid 368ccf09800a3f16b9a5b52421dfb5f12
wwid 36006016023003e00fcfe745e7b1b2803
wwid 36000d31001531000000000000000000d
wwid 368ccf098003d9738b55340fbd8933bcb
wwid 368ccf09800ed2243662b7ad4cb51e8f9
wwid 36006016005704c00ba3ba75d721dacf2
wwid 36006016005704c00a03ba75dd9f097c2
}
- After completing your edits, restart the multipath service on one or more Linux Hosts:
# /bin/systemctl restart multipathd.service
Note: Alternatively, reboot your Linux Host to re load the service and connections.
- From PowerStore Manager, refresh the Host volumes and then retry the Import operation:
PowerStore Manager > Migration > Import External Storage > Select the remote system > IMPORT STORAGE > Select the Volume > REFRESH ACTIONS > Refresh Hosts and Refresh Volumes