PowerStore: Unable to connect to a node using Serial Over LAN (SOL) with IPMI
Summary: This article how to resolve Serial Over LAN failures to connect with IPMI.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
When connected to a node using Serial Over LAN (SOL) with IPMI, the connection may become unresponsive, or you may see one of the following errors.
Example:
Example:
Example:
C:\User>ipmitool -I lanplus -H 128.221.1.252 -C 3 -U console -P <SVC_TAG> sol activate |
Example:
C:\User>ipmitool -I lanplus -H 128.221.1.252 -C 3 -U console -P <SVC_TAG> sol activate |
Cause
There are different issues that can cause this. The resolution section describes a few.
The laptop can be physically connected to the PowerStore on either Service LAN Port, or both (using a small switch or hub).
ATTENTION: Never connect multiple appliances to the same hub or switch for Service LAN Port access.
The laptop can be physically connected to the PowerStore on either Service LAN Port, or both (using a small switch or hub).
ATTENTION: Never connect multiple appliances to the same hub or switch for Service LAN Port access.
Resolution
There are a few flags that can be used to help you better understand the issue.
-v: High-level verbose information.
C:\User>ipmitool -I lanplus -H 128.221.1.252 -C 3 -U console -P <SVC_TAG> -v sol activate |
-vvv: Low-level verbose information.
C:\User>ipmitool -I lanplus -H 128.221.1.252 -C 3 -U console -P <SVC_TAG> -vvv sol activate |
Error Activating SOL payload
This may indicate that an existing session is still active.
Deactivate the SOL session with:
C:\User>ipmitool -I lanplus -H 128.221.1.252 -C 3 -U console -P <SVC_TAG> sol deactivate |
Then activate the SOL session again with:
C:\User>ipmitool -I lanplus -H 128.221.1.252 -C 3 -U console -P <SVC_TAG> sol activate |
Incorrect password
C:\User>ipmitool -I lanplus -H 128.221.1.252 -C 3 -U console -P <SVC_TAG> -v sol activate |
Ensure you have the correct password. Passwords are based on the appliance that you are connected to. Each appliance has a different Dell Service Tag, and a different password.
RAKP 2 HMAC is invalid.
C:\User>ipmitool -I lanplus -H 128.221.1.252 -C 3 -U console -P <SVC_TAG> -v sol activate |
Ensure that the IPMI Service LAN port is not connected to a switch or hub, as this error commonly indicates duplicate IPs.
Affected Products
PowerStoreArticle Properties
Article Number: 000131664
Article Type: Solution
Last Modified: 20 Jul 2022
Version: 5
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