FPS or CPU Drops when Playing Games or 3D Apps on Dell Gaming Laptops
Summary: Learn more about how to manage the thermal handling built into Dell gaming laptops. It mitigates any Frame Per Second (FPS) drop after long periods of use.
Symptoms
The FPS drops in Dell Gaming laptops while running games or 3D applications. Sudden drops and processing problems are seen when running them for long periods of time.
This behavior typically occurs after the laptop has been in use for some time. Using monitoring software it is possible to see the following symptoms:
- When the temperature of the processor heats up, the laptop has to:
- Lower the speed of the Central Processing Unit (CPU) or Graphics Processing Unit (GPU) to stop the laptop from overheating.
- Lower the power to the CPU or GPU to prevent the laptop from overheating.
- When it lowers the speed or power of the CPU or GPU:
- It can drop the processor clock to 0.8 GHz.
- The FPS also drops.
Affected Platforms:
- Dell G3 3579 and 3590
- Dell G5 5587
- Dell G7 7588
- Inspiron 7567
Cause
It is the expected behavior of a laptop that during continuous usage it heats up. (Especially when using graphical or 3D applications that require a lot of hardware resources.) The thermal handling feature gradually lowers the processing speed of the CPU and GPU when the warming reaches a certain point. That point varies depending on the laptops specifications.
Resolution
The laptop is working as expected when it reduces the temperature. It does this so that excess heat does not damage any components in the laptop.
To prevent this feature from activating frequently to ensure that the laptop is not heating up abnormally or overheating.
Important Tips:
- Ensure that the BIOS and drivers are updated to the latest version available for the laptop from the: Dell Support Site
- Ensure that none of the ventilation openings on the laptop are obstructed.
- Ensure that the environmental temperature of the laptops physical location is causing the temperature of the laptop to rise faster than expected.
- Do not use third-party software to determine if the laptop is overheating. Use the stress test in SupportAssist to check if any errors are reported:
- Adjust the configuration of the Thermal Management option according to what is required if the laptop supports the Dell Power Manager (DPM) utility: