MCE Errors May Be Generated on Unsupported Systems Running Linux

Summary: This article addresses MCE log errors that Linux users may encounter. Systems running Ubuntu ®, SUSE, & RedHat may experience MCE log errors on the Kabylake platform.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

MCE Log Errors

You may find reports or logs of MCE errors indicating Intel hardware platform is not recognized or valid. This is a known condition of running MCE on un-supported platforms. Currently MCE logs are compatible with chipset generations up to the Skylake and these errors can be expected on the KabyLake generation of processors.


To check compatibility of MCELog tool with your hardware platform:

  1. In Root Terminal Execute: $ mcelog –help

    This command will return an output of all available commands followed with a list of "Valid CPU’s"

  2. Next run the command: $ mcelog –is-cpu-supported

    This command will return a list of valid CPU generations. If the hardware is not supported you may see other outputs such as:

    • "Mcelog: Family 6 Model 9e CPU: only decoding architectural errors"

Cause

Unsupported platforms.

Resolution

Do not accept any error logs from MCE logging tools unless the "—is-cpu-supported" (figure 1.1 part "A.") flag returns a value that matches with a value shown in the list of "Valid CPU’s" (Figure 1.1 part "B.").

The example below does not match and as such, is not a supported platform.

MCE Errors illustrated


ADDITIONAL RESOURCES:

 

 

 

 

Affected Products

Software
Article Properties
Article Number: 000133485
Article Type: Solution
Last Modified: 17 Jun 2021
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.