PowerFlex 设备已修复读取错误

Summary: SDS 设备出现错误,指出“设备已修复读取错误”。

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

情况说明

当 SDS 设备具有由 SDS 纠正的读取错误时,可能会发生这种情况。

当后台扫描程序处于禁用或启用状态时,可能会发生这种情况。

症状

设备上已修复的错误可在以下位置显示:

  • GUI 显示错误:

  • “--query_sds --sds_id <SDS_ID>”输出显示具有更正读取错误的每个设备的计数器:

15: Name: /dev/sdr Path: /dev/sdr Original-path: /dev/sdr ID: 2d63f7c80003000e
           Storage Pool: SAS_pool1, Capacity: 1116 GB Error-fixes: 6 scanned 0 MB, Compare errors: 0 State: Normal

MDM getInfoDump 中的counters_dump.txt显示不同对象上的FIXED_READ_ERROR_COUNT:

ID: df7700a600120012 DEVICE_TYPE                READ_ERR                                    FIXED_READ_ERROR_COUNT   1
ID: 1d1e4e5500000012 SDS_TYPE                   READ_ERR                                    FIXED_READ_ERROR_COUNT   1
ID: 1c34e1f700000007 STORAGE_POOL_TYPE          READ_ERR                                    FIXED_READ_ERROR_COUNT   1
ID: b9b286df00000001 PROTECTION_DOMAIN_TYPE     READ_ERR                                    FIXED_READ_ERROR_COUNT   1
ID: 49b6b8057d1fc84b SYSTEM_TYPE                READ_ERR                                    FIXED_READ_ERROR_COUNT   1
提醒:MDM 事件日志中没有事件指示出现此“已修复读取错误”情况。

其他可能的症状:设备可能处于错误状态。系统消息或系统日志中可能存在有关块设备上的错误:

blk_update_request: critical medium error, dev sdr, sector 94390272
  sd 0:2:15:0: [sdr] tag#1 FAILED Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
  sd 0:2:15:0: [sdr] tag#1 Sense Key : Medium Error [current] 
  sd 0:2:15:0: [sdr] tag#1 Add. Sense: Unrecovered read error

SDS trc 中可能存在较长的飞行 IO 消息:

contDevMngr_HandleLongInflightIoViolation:02998: IO on devId: 2d63f7c80003000e (/dev/sdr) took too long, Low threshold exceeded - waited for reaper 12250 millis
contDevMngr_HandleLongInflightIoViolation:02998: IO on devId: 2d63f7c80003000e (/dev/sdr) took too long, Low threshold exceeded - waited for reaper 13250 millis
contDevMngr_HandleLongInflightIoViolation:02998: IO on devId: 2d63f7c80003000e (/dev/sdr) took too long, Low threshold exceeded - waited for reaper 14250 millis

SDS sdbg_out.txt中的设备 I/O 计数器中可能存在错误:

13: Dev path:/dev/sdr Size(lbs):0 Time grn:520577464
  Io Counters:
   GENERAL
     Writes: 4852 Lbs: 2160443 MBs: 1054 Errors: 0
     Reads: 49283 Lbs: 111376 MBs: 54 Errors: 12744
   BM
     Writes: 0 Lbs: 0 MBs: 0 Errors: 0
     Reads: 0 Lbs: 0 MBs: 0 Errors: 0
   COMB_MAP
     Writes: 5 Lbs: 1390 MBs: 0 Errors: 2
     Reads: 0 Lbs: 0 MBs: 0 Errors: 0
   TOOTH_MAP
     Writes: 426 Lbs: 688528 MBs: 336 Errors: 424
     Reads: 0 Lbs: 0 MBs: 0 Errors: 0
   IO
     Writes: 4319 Lbs: 603064 MBs: 294 Errors: 16
     Reads: 2076 Lbs: 16608 MBs: 8 Errors: 22

根据以下counters_dump.txt,设备的延迟可能很高:

ID: 2d63f7c60003000c DEVICE_TYPE                DEV_LATENCY                          AVG_WRITE_LATENCY_IN_MICROSEC   0
ID: 2d63f7c70003000d DEVICE_TYPE                DEV_LATENCY                          AVG_WRITE_LATENCY_IN_MICROSEC   0
ID: 2d63f7c80003000e DEVICE_TYPE                DEV_LATENCY                          AVG_WRITE_LATENCY_IN_MICROSEC   11424
ID: 2d63f7c90003000f DEVICE_TYPE                DEV_LATENCY                          AVG_WRITE_LATENCY_IN_MICROSEC   0
ID: 2d63f7ca00030010 DEVICE_TYPE                DEV_LATENCY                          AVG_WRITE_LATENCY_IN_MICROSEC   0

 

影响

“Fixed Read Errors”计数器不会对系统产生任何直接影响。

但是,它可能表示可能导致 SDS 断开连接、重建活动等的潜在条件。

Cause

当 SDS 设备使用镜像拷贝更正或修复的读取错误时,就会出现这种情况。在以下情况下可能会发生更正:      

  • 后台扫描程序无法从数据的一个拷贝读取数据,并使用另一个拷贝来覆盖数据。
  • 由于无法读取磁盘,SDS 无法处理 SDC 的读取请求,并使用辅助副本来处理 I/O 并覆盖本地数据。

警告表示磁盘可能正在变慢、变坏或具有坏块。上述机制重写块,可以修复“软”坏块。

Resolution

  • 检查磁盘。如有必要,请联系硬件供应商进行更换。
    计数器通常表示存在潜在情况,并且磁盘正在损坏。上述 SDS作是尝试修复软坏块,但可能无法在所有情况下成功。
     
  • 清空计数器。

scli --reset_scanner_error_counters --protection_domain_id <pd id> --storage_pool_id <sp id> --reset_corrected_read_error_counter
Article Properties
Article Number: 000174344
Article Type: Solution
Last Modified: 19 Sep 2025
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.