Služba SourceOne Email Management nededuplikuje zprávy deníku Microsoft Exchange Online (o365)
Summary: Při archivaci zpráv deníku Microsoft Exchange Online (o365) nemusí dojít k deduplikaci zpráv.
Symptoms
Pokud je Microsoft Exchange Online (o365) nakonfigurovaný s ukládáním do deníku na základě pravidel, správa e-mailů SourceOne nemusí tyto zprávy deduplikovat během příjmu dat deníku SourceOne.
Stejné zprávy se ingestují do SourceOne s různými hodnotami SourceOne MessageID.
Na místních serverech Microsoft Exchange jsou stejné zprávy Rule Base Journaling správně deduplikovány během příjmu dat SourceOne Journaling.
V protokolech událostí EMC ani v protokolech trasování ExJBJournal.exe.log nejsou zaznamenány žádné chyby.
Cause
Během ukládání do deníku založeného na pravidlech Microsoft Exchange Online (o365) lze do stejné poštovní schránky směrovat více kopií stejných zpráv.
Problém je v tom, že PR_SEARCH_KEY v každé kopii zprávy je jiná. SourceOne používá vlastnost PR_SEARCH_KEY zprávy jako součást svého algoritmu k vygenerování jedinečného SourceOne MessageID.
I když se zprávy mohou zobrazit stejně, protože PR_SEARCH_KEY je odlišný, nástroj SourceOne identifikuje tyto zprávy jako odlišné a v důsledku toho vygeneruje odlišné jedinečné ID zprávy SourceOne.
Vlastnost PR_SEARCH_KEY lze zobrazit pomocí nástroje MFCMAPI.
Resolution
Chcete-li zjistit, proč má více kopií stejných zpráv v poštovní schránce Ukládání do deníku různé hodnoty vlastností PR_SEARCH_KEY, obraťte se na technickou podporu společnosti Microsoft.
Alternativním řešením je použití ukládání do deníku SMTP serveru Microsoft Exchange namísto ukládání do deníku na základě pravidel. Další informace o konfiguraci deníku SMTP serveru Microsoft Exchange pro práci se Správou e-mailu serveru SourceOne naleznete v instalační příručce pro správu e-mailu serveru SourceOne na adrese https://dell.com/support.