SourceOne Email Management ne déduplique pas les messages journalisés de Microsoft Exchange Online (o365)
Summary: Lors de l’archivage des messages journalisés de Microsoft Exchange Online (o365), il se peut que les messages ne soient pas dédupliqués.
Symptoms
Lorsque Microsoft Exchange Online (o365) est configuré avec la journalisation basée sur des règles, SourceOne Email Management peut ne pas dédupliquer ces messages lors de l’ingestion de SourceOne Journaling.
Les mêmes messages peuvent être ingérés dans SourceOne avec différentes valeurs SourceOne MessageID.
Dans les serveurs Microsoft Exchange sur site, les mêmes messages de journalisation de base de règles sont correctement dédupliqués lors de l’ingestion de la journalisation SourceOne.
Aucune erreur n’est consignée dans les journaux d’événements EMC ou les journaux de suivi ExJBJournal.exe.log.
Cause
Au cours de la journalisation basée sur des règles Microsoft Exchange Online (o365), plusieurs copies des mêmes messages peuvent être acheminées vers la même boîte aux lettres de journalisation.
Le problème est que la PR_SEARCH_KEY dans chaque copie du message est différente. SourceOne utilise la propriété PR_SEARCH_KEY d’un message dans le cadre de son algorithme pour générer un SourceOne MessageID unique.
Bien que les messages puissent sembler identiques, étant donné que le PR_SEARCH_KEY est différent, SourceOne identifie ces messages comme différents et, par conséquent, génère un ID de message SourceOne unique différent.
La propriété PR_SEARCH_KEY peut être affichée à l’aide de l’utilitaire MFCMAPI.
Resolution
Afin d’identifier pourquoi plusieurs copies des mêmes messages dans la boîte aux lettres de journalisation ont des valeurs de propriété de PR_SEARCH_KEY différentes, contactez le support technique Microsoft.
Pour contourner ce problème, utilisez la journalisation SMTP Microsoft Exchange au lieu de la journalisation basée sur des règles. Pour plus d’informations sur la configuration de la journalisation SMTP Microsoft Exchange pour fonctionner avec SourceOne Email Management, consultez le Guide d’installation de SourceOne Email Management à https://dell.com/support.