SourceOne Email Management deduplicerar inte Microsoft Exchange Online-journalmeddelanden (o365)
Summary: Vid arkivering av Microsoft Exchange Online-journalmeddelanden (o365) kan det hända att meddelanden inte dedupliceras.
Symptoms
När Microsoft Exchange Online (o365) har konfigurerats med regelbaserad journalföring kan det hända att SourceOne Email Management inte deduplicerar dessa meddelanden under inmatning av SourceOne Journaling.
Samma meddelanden kan ses matas in i SourceOne med olika SourceOne MessageID-värden.
På lokala Microsoft Exchange-servrar dedupliceras samma regelbasjournaler korrekt under inmatning av SourceOne Journaling.
Inga fel loggas i EMC-händelseloggarna eller de ExJBJournal.exe.log spårningsloggarna.
Cause
Under regelbaserad journalföring i Microsoft Exchange Online (o365) kan flera kopior av samma meddelanden dirigeras till samma journalpostlåda.
Problemet är att PR_SEARCH_KEY i varje kopia av meddelandet är olika. SourceOne använder egenskapen PR_SEARCH_KEY för ett meddelande som en del av algoritmen för att generera ett unikt SourceOne MessageID.
Även om meddelandena kan se likadana ut, eftersom PR_SEARCH_KEY är olika, identifierar SourceOne dessa meddelanden som olika och genererar därför ett annat unikt SourceOne MessageID.
Egenskapen PR_SEARCH_KEY kan visas med hjälp av MFCMAPI-verktyget.
Resolution
Kontakta Microsofts tekniska support om du vill ta reda på varför flera kopior av samma meddelanden i postlådan Journalföring har olika PR_SEARCH_KEY egenskapsvärden.
Som en tillfällig lösning kan du använda Microsoft Exchange SMTP-journalföring i stället för regelbaserad journalföring. Mer information om hur du konfigurerar Microsoft Exchange SMTP-journalföring så att den fungerar med SourceOne Email Management finns i installationsguiden för SourceOne Email Management på https://dell.com/support.