SRM 4.5: Web Service Gateway (WSG) service not running after upgrading to 4.5 or 4.5.0.1: "Insufficient configured threads" exception
Summary: The Web Service Gateway (WSG) service fails to start on SRM 4.5 and 4.5.0.1 VMs or hosts with more than 16 CPU cores. This also affects SRM upgrades to 4.5 and 4.5.0.1.
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Symptoms
Two potential symptoms are associated with the issue described in this KB article:
- Below SRM upgrades may stall soon after entering Maintenance Mode and do not complete
(i) Upgrade from 4.5 to 4.5.0.1
(ii) Upgrade from previous versions to 4.5 - On SRM 4.5 or 4.5.0.1, the WSG service does not start on VMs or hosts and logs the following errors:
SEVERE -- [2021-02-08 14:38:00 AEDT] -- HttpServer$Service::publish(): an unexpected error occurred publishing com.watch4net.apg.webservice.proxy.ManagementServiceProxyHandler
java.lang.IllegalStateException: handler can't be initialized
(...)
Caused by: javax.servlet.ServletException: java.lang.IllegalStateException: Insufficient configured threads: required=14 < max=10 for QueuedThreadPool[ProxyHandler]@72967906{STOPPED,8<=0<=10,i=0,r=-1,q=0}[NO_TRY]
(...)
Caused by: java.lang.IllegalStateException: Insufficient configured threads: required=14 < max=10 for QueuedThreadPool[ProxyHandler]@72967906{STOPPED,8<=0<=10,i=0,r=-1,q=0}[NO_TRY]
The issue affects both Linux/vApp and Windows hosts.
Cause
The WSG is using Jetty, a Java web server and Java Servlet container. Jetty is unable to allocate enough threads for the required processes. The number of threads that one sees at any one point can vary greatly, based on hardware differences (number of CPU cores, number of network interfaces, kernel differences, Java differences, load differences, active user counts, active connection counts, transactions per second, etc.) Usually, VMs and hosts with more than 16 virtual processors are known to have this issue.
Resolution
On any SRM Server, if the CPU core count is higher than 16, WSG logs show errors about insufficient threads to start the WSG service. The latest Jetty upgrade to 9.4.34 or higher requires a re-configuration of the default max number of threads count (#10) to create sufficient threads.
If you have more than 16 CPU cores on your SRM VM or host, please go to the Dell EMC Online Support site (https://dell.com/support) to open a Service Request (SR) and reference this Knowledgebase article number in your SR.
If you have more than 16 CPU cores on your SRM VM or host, please go to the Dell EMC Online Support site (https://dell.com/support) to open a Service Request (SR) and reference this Knowledgebase article number in your SR.
Products
SRM, SRMArticle Properties
Article Number: 000184212
Article Type: Solution
Last Modified: 29 Aug 2022
Version: 6
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