NetWorker Module for Databases & Applications: Kan DB2-client niet wijzigen vanuit wizard op NMC

Summary: Bij het wijzigen van een DB2-client vanuit de NetWorker Management Console (NMC) mislukt de verbinding omdat de database de status in afwachting van back-ups heeft (SQLSTATE=57019).

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

NetWorker Module for Databases and Applications (NMDA) DB2 kan de DB2-clientwizard niet wijzigen in de NetWorker Management Console (NMC).

De weergegeven fout is:
Db2 returned the following error message
unable to connect to sample database due to sql connection failure SQLERROR:-1
SQL1116N: a connection to or activation of database "sample" failed because the database is in backup pending state SQLSTATE=57019
DB2-transactieregistratie is gewijzigd van circulair naar archiefregistratie.

Cause

Wanneer de logboekmodus wordt gewijzigd van Circulair naar Archiveren, wordt de waarde voor back-ups in behandeling gewijzigd in 'JA'.

Wanneer de databasestatus in back-up in behandeling is, kunnen de databaseobjecten niet worden geopend.

Voor een query voert u de volgende opdracht uit: db2 get db cfg for sample | grep backup pending
It returns value as backup pending = YES.

Resolution

Er moet een offline back-up worden uitgevoerd om de status back-up in behandeling uit te schakelen.

Voer een van beide client-side NMDA handmatige DB2 back-ups uit, bijvoorbeeld:
db2 backup db <db name> load /usr/lib/libnsrdb2.so options @/<path/to/db_backup.cfg> zonder daarom te vragen

Of volg de stappen in het onderstaande IBM-artikel om een offline native back-up uit te voeren.


https://www.ibm.com/docs/en/license-metric-tool?topic=database-backing-up-db2 Nadat de back-up is voltooid, wordt de waarde voor de back-up die in behandeling is gewijzigd in 'NEE' en kan de client worden gewijzigd vanuit de NMC.
Article Properties
Article Number: 000191366
Article Type: Solution
Last Modified: 09 Mar 2022
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.