NetWorker-modul for databaser og applikasjoner: Kan ikke endre DB2-klienten fra veiviseren på NMC

Summary: Når du endrer en DB2-klient fra NetWorker Management Console (NMC), mislykkes tilkoblingen fordi databasen er i ventende tilstand (SQLSTATE=57019).

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

NetWorker Module for Databases and Applications (NMDA) DB2 kan ikke endre DB2-klientveiviseren på NetWorker Management Console (NMC).

Feilen som vises, er:
Db2 returned the following error message
unable to connect to sample database due to sql connection failure SQLERROR:-1
SQL1116N: a connection to or activation of database "sample" failed because the database is in backup pending state SQLSTATE=57019
DB2-transaksjonslogging ble endret fra sirkulær til arkivlogging.

Cause

Når loggingsmodus endres fra sirkulær til arkiv, endres verdien for ventende sikkerhetskopi til "JA".

Når databasestatus er i ventende sikkerhetskopiering, får ikke databaseobjektene tilgang til.

Hvis du vil spørre kjører du kommandoen: db2 get db cfg for sample | grep backup pending
Den returnerer verdien som venter på sikkerhetskopiering = YES.

Resolution

En frakoblet sikkerhetskopiering må utføres for å slå av ventende tilstand for sikkerhetskopiering.

Utfør NMDA-manuell DB2-sikkerhetskopiering på klientsiden, for eksempel:
db2 backup db< db name> load /usr/lib/libnsrdb2.so options @/<path/to/db_backup.cfg> without prompting

Eller følg trinnene som er beskrevet i IBM-artikkelen nedenfor for å utføre en frakoblet, innebygd sikkerhetskopiering.


https://www.ibm.com/docs/en/license-metric-tool?topic=database-backing-up-db2 Når sikkerhetskopieringen er fullført, endres ventende verdi for sikkerhetskopien til 'NO', og klienten kan endres fra NMC.
Article Properties
Article Number: 000191366
Article Type: Solution
Last Modified: 09 Mar 2022
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.