Veritabanları ve Uygulamalar için NetWorker Modülü: NMC üzerinde sihirbazdan DB2 istemcisi değiştirilemiyor

Summary: NetWorker Management Console'dan (NMC) bir DB2 istemcisini değiştirirken, veritabanı yedekleme beklemede durumunda (SQLSTATE=57019) olduğundan bağlantı başarısız oluyor.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Veritabanları ve Uygulamalar için NetWorker Modülü (NMDA) DB2, NetWorker Management Console da (NMC) DB2 istemci sihirbazını değiştiremiyor.

Görüntülenen hata şudur:
Db2 returned the following error message
unable to connect to sample database due to sql connection failure SQLERROR:-1
SQL1116N: a connection to or activation of database "sample" failed because the database is in backup pending state SQLSTATE=57019
DB2 işlem günlüğü, dairesel yerine Arşiv günlüğü olarak değiştirildi.

Cause

Günlük modu Döngüsel'den Arşiv'e değiştirildiğinde, yedekleme bekleyen değeri 'YES' olarak değişir.

Veritabanı durumu yedekleme beklemede olduğunda veritabanı nesnelerine erişilemez.

Sorgulamak için şu komutu çalıştırın: db2 get db cfg for sample | grep backup pending
Değeri yedekleme beklemede = YES olarak döndürür.

Resolution

Yedekleme beklemede durumunu kapatmak için çevrimdışı yedekleme gerçekleştirilmelidir.

İstemci tarafı NMDA manuel DB2 yedeklemesi gerçekleştirin, örneğin:
DB2 Backup DB <Name> load /usr/lib/libnsrdb2.so seçenekleri @/<path/to/db_backup.cfg> sormadan

Alternatif olarak, çevrimdışı bir yerel yedekleme gerçekleştirmek için aşağıdaki IBM makalesinde özetlenen adımları izleyin.


https://www.ibm.com/docs/en/license-metric-tool?topic=database-backing-up-db2 Yedekleme başarıyla tamamlandıktan sonra, yedekleme bekleyen değeri "NO" olarak değişir ve istemci NMC'den değiştirilebilir.
Article Properties
Article Number: 000191366
Article Type: Solution
Last Modified: 09 Mar 2022
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.