PowerStore: D@RE Encryption key issue that may cause a data integrity issue

Summary: The D@RE encryption keys may be lost on systems running 2.0.0.0 if a disk is inserted into an array after the initial installation.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

D@RE keys are not properly assigned to drive.

Cause

Dell Technologies has identified a rare condition that can occur on systems running PowerStore 2.0.0.0 code. This condition can be introduced through the following events:
  • Remove a disk and reinsert the same disk after 5 minutes.
  • Insert a new disk as a replacement for a failed disk.
  • Add new disks as part of a capacity upgrade.
Once introduced a data impactful event can occur after certain High Availability Events (Node Reboot, Node Replacement, and so on). This impact results in data on the disk or disks in the above activities to be compromised.

Resolution

  • To prevent any risk of this issue, we recommend you upgrade to the PowerStoreOS 2.0.1.0 or later code immediately.
  • If you are on 2.0.0.0 code and are replacing a drive, Please follow these steps:
  1. Remove drive from chassis.

  2. Allow rebuild to complete.

  3. Perform upgrade to the PowerStoreOS 2.0.1.0. 

  4. Replace faulted drive that was removed in first step.

  • If you have encountered the "encryption key check failed" error during a health check, do not reboot the nodes and seek immediate assistance, quoting this article.
  • For more information about the Pre Upgrade Health Check failure review PowerStore: Health Check: Platform DARE Drive No Encryption Key Check Failed.
  • If you cannot perform the above steps or upgrade at this time, though highly recommended,  please  contact Dell Technologies Technical Support and reference this Knowledge Base Article.

NOTE TO CLOUDIQ USERS: Upon detecting this issue, it is added to the Health Issues List. Depending on other detected issues this may modify the Health Score by up to 45 (45) points. This issue is removed from the Health Issues List upon upgrading to 2.0.1.0 or greater. Remember that it takes a minimum of 24 hours for the changes to be reflected in the Health Score.
For more information about CloudIQ, and for information about how to get connected, go to the CloudIQ page on the Dell Technologies website.

Affected Products

PowerStore
Article Properties
Article Number: 000191410
Article Type: Solution
Last Modified: 02 Dec 2022
Version:  11
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.