PowerStore: Inkonsekventa logiska enhetsnummer mellan värdar kan leda till problem med dataåtkomst eller datakonsekvens

Summary: Felmatchade logiska enhetsnummer kan leda till att data blir otillgängliga eller att data går förlorade (DU/DL).

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

I vissa konfigurationer, som start från SAN, krävs en lagringsadministratör för att mappa PowerStore-volymer till enskilda värdar i stället för värdgrupper.
PowerStore har för närvarande inte stöd för mappning av volymer individuellt till en värd som redan är medlem i en värdgrupp.
När volymer mappas till värdar i stället för värdgrupper måste administratören manuellt tilldela matchande logiska enhetsnummer för varje volym till varje värd.


Det här avsnittet beskrivs i värdkonfigurationsmanualen för PowerStore under avsnittet Boot from SAN:
"Följ dessa riktlinjer för klustrad start från SAN-mappning:
  • För varje fysisk värd bör det finnas en värd i PowerStore Manager. Skapa inte en värdgrupp.
  • Start-LUN mappas endast för den specifika värden.
  • Delade LUN mappas till alla värdar i klustret. Användaren måste behålla samma LUN-ID i klustret för delade LUN-enheter."



Identifiera problemet:

Du kan visa alla logiska enhetsnummer från PowerStore Manager i volymavsnittet och sedan på fliken HOST MAPPINGS .

Det här är ett exempel på en problematisk konfiguration (felmatchade logiska enhetsnummer):
image.png
 

Cause

I klustermiljöer ska olika värdar få åtkomst till samma delade volym med samma logiska enhetsnummer.
Felmatchade logiska enhetsnummer kan leda till att data blir otillgängliga eller att data går förlorade (DU/DL).

Resolution

Beroende på miljöns storlek och omfattning och möjligheten att lägga till eller separera värdinitierare kan ett av följande två alternativ användas: 

1) Lagringsadministratören måste matcha logiska enhetsnummer för varje volym för varje värd. 
  1. Arbeta med varje värd var för sig i underhållsläge.
  2. Avmappa alla volymer från värden och lämna endast start från SAN-volymen, vanligtvis LUN 0.
  3. Mappa om de delade datavolymerna till värden och tilldela manuellt numren för logiska enheter. 
  4. Skanna om värd-HBA:er och kontrollera lagringstillgänglighet. 
  5. Starta om värden för att säkerställa korrekt start och bekräfta tillgänglighets- och logiska enhetsnummer. 
  6. Avsluta underhållsläget.
  7. Upprepa steg 1 till 6 på alla återstående värdar och se till att logiskt enhetsnummer är konsekventa för varje volym för alla värdar.
  8. Införliva det här arbetsflödet med manuellt logiskt enhetsnummermatchning mellan alla värdar för framtida volymmappningar.

2) Om tillgängligt, för varje värd, ansluter du ytterligare och redundanta FC-portar till strukturerna. Använd nyligen synliga WWN:er för att skapa nya värdobjekt i PowerStore och associera värdobjektet med en värdgrupp. Använd värdgruppen för att mappa alla aktuella och framtida datavolymer (inte startvolymerna).
  1. Arbeta med varje värd var för sig i underhållsläge.
  2. Avmappa alla datavolymer från värden, lämna endast start från SAN LUN, vanligtvis LUN 0.
  3. Provisionering och zonindeablering av ytterligare redundanta WWN från värden till PowerStore enligt bästa praxis. 
  4. Skapa en ny värd- och värdgrupp med hjälp av de nyligen synliga initierarport-ID:erna. 
  5. Mappa alla delade datavolymer till den nya värdgruppen och använd alternativet för att automatiskt generera det logiska enhetsnumret.
  6. Skanna om värd-HBA:er och kontrollera lagringstillgänglighet. 
  7. Starta om värden för att säkerställa korrekt start och bekräfta datatillgänglighet. 
  8. Avsluta underhållsläget. 
  9. Upprepa steg 1 till 8 på alla återstående värdar genom att lägga till det nyskapade värdobjektet i den nya värdgruppen.
  10. Mappa alla nya datavolymer till värdgruppen. 

Additional Information

Om du skapar dessa volymer för första gången får du den här vägledningen:
image.png

Videos


Affected Products

PowerStore
Article Properties
Article Number: 000191503
Article Type: Solution
Last Modified: 12 Jan 2023
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.