PowerEdge:Windows - 系統開機至「套用更新操作C0190019發生錯誤」

Summary: 本文提供解決 Windows 中特定無開機狀況的步驟:「套用更新作業 x / y (檔案名稱C0190019發生錯誤)」

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Windows 無法開機,並卡在螢幕上,顯示 Windows 標誌和訊息「套用更新作業 x x of y檔案名稱)C0190019發生錯誤」。x 和 y 表示的數位各不相同,檔名也各不相同。

Cause

已知兩個可能的原因:

  1. C: 磁碟機已滿或接近滿。
  2. 更新 Windows 的過程中發生問題。

Resolution

發生此問題時,Windows 無法開機。開機至安全模式會產生相同的錯誤畫面。Windows 修復環境 (WinRE) 是唯一可行的故障診斷選項。

可透過開機至作業系統媒體來連線 WinRE。如果沒有可用的媒體,系統也會在幾次開機失敗後自動開機至 WinRE。

系統開機進入 WinRE 後,請執行下列步驟:

  1. 選擇選項 功能表中,選取 故障診斷
  2. 進階選項 功能表中,選取 命令提示字元
  3. 如果出現提示,請提供管理憑據。
  4. 出現提示時,輸入 diskpart
  5. Diskpart 提示,鍵入 list vol 若要判斷 Windows 所安裝磁碟區的磁碟機代號。在 WinRE 中,它可能是也可能不是 C:
  6. 輸入 exit 若要關閉 Diskpart
  7. 切換至步驟 5 取得的磁碟機。
  8. 輸入 dir 並檢查輸出底部列出的可用空間量。
  9. 如果命令的輸出指出可用空間不足,請判斷哪些檔案可以刪除或移動到另一個磁碟機。釋放空間後,將伺服器重新開機。如果錯誤仍然存在,請重複步驟 1-7,然後再繼續。
  10. 執行下列命令以復原任何擱置中的 Windows 更新,並將 X: 更換為步驟 5 中取得的磁碟機代號:(此命令可能需要幾分鐘才能完成。)
    dism /image:X:\ /cleanup-image /revertpendingactions
  11. 命令完成後,執行此命令以檢查元件儲存區中的損毀情況,並再次將 X: 替換為步驟 5 的磁碟機代號:(此命令也需要一些時間才能完成。
    dism /image:X:\ /cleanup-image /scanhealth
    
  12. 如果上一個命令指示元件存儲中存在損壞,請執行此命令以嘗試修復它,並再次將 X: 替換為步驟 5 中的驅動器號:(同樣地,此命令需要一段時間。如果上一個命令未發現損壞,請跳過此步驟。
    dism /image:X:\ /cleanup-image /restorehealth
  13. 輸入 exit 以關閉命令提示字元,並返回 選擇選項 功能表。
  14. 一下關閉電腦
  15. 系統關機後,請重新開啟電源。它可能會執行自動啟動修復,但隨後應會開機進入 Windows。

Affected Products

Microsoft Windows Server 2016, Microsoft Windows Server 2019, Microsoft Windows Server 2022, Microsoft Windows Server 2025, Poweredge C4140, PowerEdge C6420, PowerEdge C6520, PowerEdge C6525, PowerEdge C6615, PowerEdge C6620, PowerEdge FC640 , PowerEdge HS5610, PowerEdge HS5620, PowerEdge M640, PowerEdge M640 (for PE VRTX), PowerEdge MX740C, PowerEdge MX840C, PowerEdge R260, PowerEdge R360, PowerEdge R470, PowerEdge R540, PowerEdge R550, PowerEdge R570, PowerEdge R640, PowerEdge R6415, PowerEdge R650, PowerEdge R650xs, PowerEdge R6515, PowerEdge R6525, PowerEdge R660, PowerEdge R660xs, PowerEdge R6615, PowerEdge R6625, PowerEdge R670, PowerEdge R740, PowerEdge R740XD, PowerEdge R740XD2, PowerEdge R7415, PowerEdge R7425, PowerEdge R750, PowerEdge R750XA, PowerEdge R750xs, PowerEdge R7515, PowerEdge R7525, PowerEdge R760, PowerEdge R760XA, PowerEdge R760xd2, PowerEdge R760xs, PowerEdge R7615, PowerEdge R7625, PowerEdge R770, PowerEdge R7715, PowerEdge R7725, PowerEdge R840, PowerEdge R860, PowerEdge R940, PowerEdge R940xa, PowerEdge R960, PowerEdge T340, PowerEdge T350, PowerEdge T360, PowerEdge T440, PowerEdge T550, PowerEdge T560, PowerEdge T640 ...
Article Properties
Article Number: 000194588
Article Type: Solution
Last Modified: 07 May 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.