Los informes y análisis (DPA) muestran el servicio de aplicaciones y la interfaz de usuario de administración del servidor de aplicaciones en rojo en ACM después de la actualización a IDPA 2.7 o 2.7.1

Summary: En este artículo de la base de conocimientos, se explica cómo solucionar los servicios de aplicaciones de DPA que no se inician después de la actualización a IDPA 2.7 o 2.7.1.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Después de actualizar a IDPA 2.7 o 2.7.1, los servicios de aplicaciones de informes y análisis (DPA) no se inician y muestran marcas rojas en la interfaz del usuario de ACM. 

Captura de pantalla de ACM que muestra DPA con marcas rojas.  
 

Examinar el registro del servidor de aplicaciones de DPA ubicado en <dpa_install_path>/services/logs/server.log Se mostrarán los siguientes mensajes.
 

2021-12-27 14:14:07,113 INFO  [com.emc.apollo.serverstart.pre.PreApolloStartupBean] (ServerService Thread Pool -- 62) Server starting
2021-12-27 14:14:07,114 INFO  [com.emc.apollo.services.container.ApolloClusterServicesJbossImpl] (ServerService Thread Pool -- 62) initIsMaster set to true
2021-12-27 14:14:07,115 INFO  [com.emc.apollo.serverstart.pre.PreApolloStartupBean] (ServerService Thread Pool -- 62) Apollo Version: 19.5.0.1634796815
2021-12-27 14:14:07,117 WARN  [org.jboss.jca.core.connectionmanager.pool.strategy.PoolBySubject] (ServerService Thread Pool -- 62) IJ000604: Throwable while attempting to get a new connection: null: javax.resource.ResourceException: Could not create connection
...
Caused by: org.postgresql.util.PSQLException: Connection to <ip_address_of_DS>:9003 refused. Check that the hostname and port are correct and that the postmaster is accepting TCP/IP connections.
...
Caused by: java.net.ConnectException: Connection refused (Connection refused)
at java.net.PlainSocketImpl.socketConnect(Native Method) [rt.jar:1.8.0_301]


 

2021-12-27 14:14:07,120 ERROR [com.emc.apollo.serverstart.pre.PreApolloStartupBean] (ServerService Thread Pool -- 62) exception trying to obtain a connection to the database: com.emc.apollo.jdbc.ApolloSQLException: Could not obtain connection: javax.resource.ResourceException: IJ000453: Unable to get managed connection for java:jboss/datasources/ApolloDS
Por último, para confirmar el problema, inicie sesión en el servidor de DS de DPA mediante PUTTY/SSH como root y ejecute el siguiente comando:
dpa.sh ds con


Si el servicio APP de DPA no se está iniciando, el resultado es similar al que se muestra a continuación:

dpa.sh ds con

EMC Data Protection Advisor

[INFO] Service Bind Address(es)    : 127.0.0.1
       Client(s) Address(es)       : 127.0.0.1/32
                                     ::1/128
                                     127.0.0.1/32
                                     ::1/128
                                     <DS_ip_addresss>/32

Command completed successfully.

Where <DS_ip_addresss> is the IP Address of the DPA Datastore, example 10.0.0.20.

La identificación del problema tiene uno o ambos de los siguientes componentes:
  • En Service Bind Address(es), la dirección IP del almacén de datos de DPA no aparece en la lista.
  • En la(s) dirección(es) de cliente(s), la dirección IP de la aplicación DPA no aparece en la lista.

En este ejemplo, ambos problemas están presentes.

Un resultado adecuado de este comando debe ser el siguiente:

dpa.sh ds con

EMC Data Protection Advisor

[INFO] Service Bind Address(es)    : <DS_ip_addresss>
       Client(s) Address(es)       : 127.0.0.1/32
                                     ::1/128
                                     127.0.0.1/32
                                     ::1/128
                                     <App_ip_addresss>/32
                                     <DS_ip_addresss>/32

Command completed successfully.

Where <DS_ip_addresss> is the IP Address of the DPA Datastore, example 10.0.0.20.

Where <App_ip_addresss> is the IP Address of the DPA Application, example 10.0.0.21.

Cause

Este es un problema/defecto conocido en Data Protection Advisor.

Resolution

Este problema no se resuelve.


Hay una solución alternativa disponible para este problema. Siga los pasos que se indican a continuación.
 

NOTA: La práctica recomendada es hacer copias y respaldar todos los archivos de configuración del almacén de datos de DPA antes de ejecutar estos comandos.

Se debe realizar uno de los dos siguientes elementos. En algunos casos, solo se debe corregir la dirección de vinculación del almacén de datos de DPA y, en otros, se deben corregir tanto la dirección de vinculación del almacén de datos de DPA como la dirección del cliente para la aplicación de DPA.

Corrección de la dirección de "enlace" del almacén de datos de DPA.

1.   Ejecute el siguiente comando en el servidor del almacén de datos de DPA desde el directorio /opt/emc/epa/services/bin: 
 

dpa.sh ds con -b  <ip_address_of_the_datastore>


2.   Reinicie los servicios del área de almacenamiento de datos de DPA.

Ejecute el siguiente comando en el servidor del almacén de datos de DPA desde/:opt/emc/epa/services/bin directorio:
dpa.sh ds restart

3.   Reinicie los servicios de la aplicación de DPA. 

Ejecute el siguiente comando en el servidor de la aplicación de DPA desde /opt/emc/epa/services/bin directorio:
dpa.sh app restart


Corrección de la dirección

de cliente de la aplicación DPA1.   Ejecute el siguiente comando en el servidor del almacén de datos de DPA desde /opt/emc/epa/services/bin directorio:
 

dpa.sh ds con -a  <ip_address_of_the_dpa_application>


2.   Reinicie los servicios del área de almacenamiento de datos de DPA.

Ejecute el siguiente comando en el servidor del almacén de datos de DPA desde /opt/emc/epa/services/bin directorio:
dpa.sh ds restart
 


3.   Reinicie los servicios de la aplicación de DPA. 

Ejecute el siguiente comando en el servidor de la aplicación de DPA desde /opt/emc/epa/services/bin directorio:
dpa.sh app restart
 


Eliminación de la IP de configuración, si está presente

Si en el resultado de dpa.sh ds con ve la siguiente dirección IP en la lista, se debe eliminar:
 

10.63.62.242/32



Para eliminar esta entrada, ejecute el siguiente comando en el servidor del área de almacenamiento de datos de DPA desde /opt/emc/epa/services/bin directorio:

dpa.sh ds con -d 10.63.62.242



Comuníquese con el soporte técnico de Dell para obtener más detalles o información.

Article Properties
Article Number: 000195087
Article Type: Solution
Last Modified: 16 Apr 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.