Os relatórios e a lógica analítica (DPA) mostram o serviço de aplicativos e a interface do usuário de administração do servidor de aplicativos em vermelho no ACM após o upgrade para o IDPA 2.7 ou 2.7.1

Summary: Este artigo da KB aborda como contornar os serviços do aplicativo DPA que não iniciam após o upgrade do IDPA 2.7 ou 2.7.1.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Depois do upgrade para o IDPA 2.7 ou 2.7.1, os serviços de aplicativos de geração de relatórios e análises (DPA) não são iniciados e mostram marcas vermelhas na interface do usuário do ACM. 

Captura de tela do ACM mostrando o DPA com marcas vermelhas.  
 

Examinando o log do servidor de aplicativos do DPA localizado em <dpa_install_path>/services/logs/server.log As seguintes mensagens serão exibidas.
 

2021-12-27 14:14:07,113 INFO  [com.emc.apollo.serverstart.pre.PreApolloStartupBean] (ServerService Thread Pool -- 62) Server starting
2021-12-27 14:14:07,114 INFO  [com.emc.apollo.services.container.ApolloClusterServicesJbossImpl] (ServerService Thread Pool -- 62) initIsMaster set to true
2021-12-27 14:14:07,115 INFO  [com.emc.apollo.serverstart.pre.PreApolloStartupBean] (ServerService Thread Pool -- 62) Apollo Version: 19.5.0.1634796815
2021-12-27 14:14:07,117 WARN  [org.jboss.jca.core.connectionmanager.pool.strategy.PoolBySubject] (ServerService Thread Pool -- 62) IJ000604: Throwable while attempting to get a new connection: null: javax.resource.ResourceException: Could not create connection
...
Caused by: org.postgresql.util.PSQLException: Connection to <ip_address_of_DS>:9003 refused. Check that the hostname and port are correct and that the postmaster is accepting TCP/IP connections.
...
Caused by: java.net.ConnectException: Connection refused (Connection refused)
at java.net.PlainSocketImpl.socketConnect(Native Method) [rt.jar:1.8.0_301]


 

2021-12-27 14:14:07,120 ERROR [com.emc.apollo.serverstart.pre.PreApolloStartupBean] (ServerService Thread Pool -- 62) exception trying to obtain a connection to the database: com.emc.apollo.jdbc.ApolloSQLException: Could not obtain connection: javax.resource.ResourceException: IJ000453: Unable to get managed connection for java:jboss/datasources/ApolloDS
Por fim, para confirmar o problema, faça log-in no servidor DS do DPA usando PUTTY/SSH como root e execute o seguinte comando:
dpa.sh ds con


Se o serviço DPA APP não estiver sendo iniciado, o resultado será semelhante ao abaixo:

dpa.sh ds con

EMC Data Protection Advisor

[INFO] Service Bind Address(es)    : 127.0.0.1
       Client(s) Address(es)       : 127.0.0.1/32
                                     ::1/128
                                     127.0.0.1/32
                                     ::1/128
                                     <DS_ip_addresss>/32

Command completed successfully.

Where <DS_ip_addresss> is the IP Address of the DPA Datastore, example 10.0.0.20.

A identificação do problema tem um ou ambos os seguintes componentes:
  • Em Service Bind Address (es), o endereço IP do datastore do DPA não está listado.
  • Nos Endereço(s) do(s) cliente(s), o Endereço IP do Aplicativo DPA não está listado.

Neste exemplo, os dois problemas estão presentes.

Uma saída adequada desse comando deve ser a seguinte:

dpa.sh ds con

EMC Data Protection Advisor

[INFO] Service Bind Address(es)    : <DS_ip_addresss>
       Client(s) Address(es)       : 127.0.0.1/32
                                     ::1/128
                                     127.0.0.1/32
                                     ::1/128
                                     <App_ip_addresss>/32
                                     <DS_ip_addresss>/32

Command completed successfully.

Where <DS_ip_addresss> is the IP Address of the DPA Datastore, example 10.0.0.20.

Where <App_ip_addresss> is the IP Address of the DPA Application, example 10.0.0.21.

Cause

Esse é um problema/defeito conhecido no Data Protection Advisor.

Resolution

Não há resolução para esse problema.


Uma solução temporária está disponível para esse problema. Siga as etapas abaixo.
 

Nota: A prática recomendada é fazer cópias e fazer backup de todos os arquivos de configuração do datastore DPA antes de executar esses comandos.

Qualquer um dos dois itens a seguir deve ser executado. Em alguns casos, apenas o endereço de vinculação do repositório de dados do DPA deve ser fixo e, em outros, o endereço de vinculação do repositório de dados do DPA e o endereço do client para o aplicativo do DPA devem ser corrigidos.

Corrigindo o endereço "vinculado" do repositório de dados do DPA.

1.   Execute o seguinte comando no servidor do DPA Datastore a partir do diretório /opt/emc/epa/services/bin: 
 

dpa.sh ds con -b  <ip_address_of_the_datastore>


2.   Reinicie os serviços do DPA Datastore.

Execute o seguinte comando no servidor do DPA Datastore de /opt/emc/epa/services/bin diretório:
dpa.sh ds restart

3.   Reinicie os serviços do aplicativo DPA. 

Execute o seguinte comando no servidor APP do DPA em: /opt/emc/epa/services/bin diretório:
dpa.sh app restart


Como corrigir o endereço

do client do aplicativo DPA1.   Execute o seguinte comando no servidor do DPA Datastore em: /opt/emc/epa/services/bin diretório:
 

dpa.sh ds con -a  <ip_address_of_the_dpa_application>


2.   Reinicie os serviços do DPA Datastore.

Execute o seguinte comando no servidor do DPA Datastore em: /opt/emc/epa/services/bin diretório:
dpa.sh ds restart
 


3.   Reinicie os serviços do aplicativo DPA. 

Execute o seguinte comando no servidor APP do DPA em: /opt/emc/epa/services/bin diretório:
dpa.sh app restart
 


Como remover o IP de configuração, se houver

Se na saída de dpa.sh ds con você vir o seguinte IP listado, ele deve ser removido:
 

10.63.62.242/32



Para remover essa entrada, execute o seguinte comando no servidor do DPA Datastore em /opt/emc/epa/services/bin diretório:

dpa.sh ds con -d 10.63.62.242



Entre em contato com o suporte técnico da Dell para obter mais detalhes ou informações.

Article Properties
Article Number: 000195087
Article Type: Solution
Last Modified: 16 Apr 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.