Rapportering och analys (DPA) visar Application Service och Application Server Admin UI som rött i ACM efter uppgradering till IDPA 2.7 eller 2.7.1

Summary: I den här kunskapsbasartikeln beskrivs hur du kringgår DPA-programtjänster som inte startar efter IDPA 2.7- eller 2.7.1-uppgradering.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Efter uppgradering till IDPA 2.7 eller 2.7.1 startar inte DPA-programtjänsterna (Reporting and Analytics) och visar röda markeringar i ACM-användargränssnittet. 

Skärmbild av ACM som visar DPA med röda markeringar.  
 

Undersöka DPA-programserverloggen som finns i <dpa_install_path>/services/logs/server.log Följande meddelanden visas.
 

2021-12-27 14:14:07,113 INFO  [com.emc.apollo.serverstart.pre.PreApolloStartupBean] (ServerService Thread Pool -- 62) Server starting
2021-12-27 14:14:07,114 INFO  [com.emc.apollo.services.container.ApolloClusterServicesJbossImpl] (ServerService Thread Pool -- 62) initIsMaster set to true
2021-12-27 14:14:07,115 INFO  [com.emc.apollo.serverstart.pre.PreApolloStartupBean] (ServerService Thread Pool -- 62) Apollo Version: 19.5.0.1634796815
2021-12-27 14:14:07,117 WARN  [org.jboss.jca.core.connectionmanager.pool.strategy.PoolBySubject] (ServerService Thread Pool -- 62) IJ000604: Throwable while attempting to get a new connection: null: javax.resource.ResourceException: Could not create connection
...
Caused by: org.postgresql.util.PSQLException: Connection to <ip_address_of_DS>:9003 refused. Check that the hostname and port are correct and that the postmaster is accepting TCP/IP connections.
...
Caused by: java.net.ConnectException: Connection refused (Connection refused)
at java.net.PlainSocketImpl.socketConnect(Native Method) [rt.jar:1.8.0_301]

Och 
 

2021-12-27 14:14:07,120 ERROR [com.emc.apollo.serverstart.pre.PreApolloStartupBean] (ServerService Thread Pool -- 62) exception trying to obtain a connection to the database: com.emc.apollo.jdbc.ApolloSQLException: Could not obtain connection: javax.resource.ResourceException: IJ000453: Unable to get managed connection for java:jboss/datasources/ApolloDS
Bekräfta problemet genom att logga in på DPA DS-servern med PUTTY/SSH som root och köra följande kommando:
dpa.sh ds con


Om DPA APP-tjänsten inte startar ser utdata ut ungefär som nedan:

dpa.sh ds con

EMC Data Protection Advisor

[INFO] Service Bind Address(es)    : 127.0.0.1
       Client(s) Address(es)       : 127.0.0.1/32
                                     ::1/128
                                     127.0.0.1/32
                                     ::1/128
                                     <DS_ip_addresss>/32

Command completed successfully.

Where <DS_ip_addresss> is the IP Address of the DPA Datastore, example 10.0.0.20.

Identifieringen av problemet har antingen en eller båda av följande komponenter:
  • I tjänstbindningsadressen (er) visas inte IP-adressen för DPA-datalagringen.
  • I klientadress(er) visas inte IP-adressen för DPA-programmet.

I det här exemplet finns båda problemen.

Korrekta utdata från det här kommandot bör vara enligt nedan:

dpa.sh ds con

EMC Data Protection Advisor

[INFO] Service Bind Address(es)    : <DS_ip_addresss>
       Client(s) Address(es)       : 127.0.0.1/32
                                     ::1/128
                                     127.0.0.1/32
                                     ::1/128
                                     <App_ip_addresss>/32
                                     <DS_ip_addresss>/32

Command completed successfully.

Where <DS_ip_addresss> is the IP Address of the DPA Datastore, example 10.0.0.20.

Where <App_ip_addresss> is the IP Address of the DPA Application, example 10.0.0.21.

Cause

Det här är ett känt problem/fel i Data Protection Advisor.

Resolution

Det finns ingen lösning på det här problemet.


Det finns en lösning på det här problemet. Följ stegen nedan.
 

Obs! Bästa praxis är att göra kopior av och säkerhetskopiera alla DPA Datastore-konfigurationsfiler innan du kör dessa kommandon.

Endera av båda följande punkter måste utföras. I vissa fall måste endast DPA-datalagerbindningsadressen åtgärdas och i andra fall måste både DPA-datalagerbindningsadressen och klientadressen för DPA-programmet åtgärdas.

Åtgärda DPA-datalagrets bindningsadress.

1.   Kör följande kommando på DPA-datalagerservern från katalogen /opt/emc/epa/services/bin: 
 

dpa.sh ds con -b  <ip_address_of_the_datastore>


2.   Starta om DPA-datalagertjänsterna.

Kör följande kommando på DPA Datastore-servern från/opt/emc/epa/services/bin katalog:
dpa.sh ds restart

3.   Starta om DPA Application Services. 

Kör följande kommando på DPA APP-servern från /opt/emc/epa/services/bin katalog:
dpa.sh app restart


Åtgärda klientadressen

för DPA-programmet1.   Kör följande kommando på DPA-datalagerservern från /opt/emc/epa/services/bin katalog:
 

dpa.sh ds con -a  <ip_address_of_the_dpa_application>


2.   Starta om DPA-datalagertjänsterna.

Kör följande kommando på DPA-datalagerservern från /opt/emc/epa/services/bin katalog:
dpa.sh ds restart
 


3.   Starta om DPA Application Services. 

Kör följande kommando på DPA APP-servern från /opt/emc/epa/services/bin katalog:
dpa.sh app restart
 


Tar bort konfigurations-IP, om sådan finns;

Om du i utdata från dpa.sh ds con ser följande IP-adress listad måste den tas bort:
 

10.63.62.242/32



Ta bort den här posten genom att köra följande kommando på DPA-datalagerservern från /opt/emc/epa/services/bin katalog:

dpa.sh ds con -d 10.63.62.242



Kontakta Dells tekniska support om du vill ha mer information eller information.

Article Properties
Article Number: 000195087
Article Type: Solution
Last Modified: 16 Apr 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.