PowerStore : Échec de la mise à niveau du firmware de disque avec une erreur reçue de la plate-forme : java.lang.NullPointerException
Summary: Échec de la mise à niveau du disque avec : Réponse reçue de la plate-forme : java.lang.NullPointerException (0xE04030010003 ou 0xE04030010044)
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Échec de la mise à niveau du disque avec erreurs :
Comme indiqué dans l'interface utilisateur de PowerStore Manager :
Et :
- La mise à niveau a échoué sur l'appliance X avec le message suivant : Réponse reçue de la plate-forme : java.lang.NullPointerException (0xE04030010003)
- Réponse reçue de la plate-forme : java.lang.NullPointerException (0xE04030010044)
Comme indiqué dans l'interface utilisateur de PowerStore Manager :
Et :
Cause
Ce problème se produit lorsque cette séquence d'événements a lieu :
Lors de la mise à niveau vers la v2, l'UUID du package de disques est défini sur null dans la base de données de gestion.
Lorsque la mise à niveau du firmware de disque est tentée, l'UUID du package null entraîne l'échec de la mise à niveau avec l'erreur java.lang.NullPointerException.
- Le package de firmware de disque est téléchargé, mais n'est pas utilisé.
- Le cluster est mis à niveau de PowerStoreOS v1 vers PowerStoreOS v2.
- Une mise à niveau du firmware de disque est tentée avec le package qui a été téléchargé avant la mise à niveau de PowerStoreOS.
Lors de la mise à niveau vers la v2, l'UUID du package de disques est défini sur null dans la base de données de gestion.
Lorsque la mise à niveau du firmware de disque est tentée, l'UUID du package null entraîne l'échec de la mise à niveau avec l'erreur java.lang.NullPointerException.
Resolution
Les références à l'ancien package de firmware de disque doivent être supprimées manuellement et l'état de la mise à niveau doit être effacé. Une fois cette opération effectuée, le package de mise à niveau du firmware de disque peut être téléchargé à nouveau et la mise à niveau peut se poursuivre.
Contactez le support technique Dell EMC ou votre responsable de service agréé et indiquez l'ID de cet article de la base de connaissances.
Contactez le support technique Dell EMC ou votre responsable de service agréé et indiquez l'ID de cet article de la base de connaissances.
Affected Products
PowerStore, PowerStore 1000X, PowerStore 1000T, PowerStore 3000X, PowerStore 3000T, PowerStore 5000X, PowerStore 5000T, PowerStore 500T, PowerStore 7000X, PowerStore 7000TProducts
PowerStore 9000X, PowerStore 9000TArticle Properties
Article Number: 000196852
Article Type: Solution
Last Modified: 30 Dec 2022
Version: 6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.