PowerStore: Aktualizacja oprogramowania wewnętrznego dysku kończy się niepowodzeniem z błędem Received response from platform: java.lang.NullPointerException
Summary: Aktualizacja dysku kończy się niepowodzeniem z komunikatem: Received response from platform: java.lang.NullPointerException (0xE04030010003 or 0xE04030010044)
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Aktualizacja dysku kończy się niepowodzeniem z błędami:
Jak widać w interfejsie użytkownika PowerStore Manager:
Oraz:
- Aktualizacja nie powiodła się w urządzeniu X z następującym komunikatem: Received response from platform: java.lang.NullPointerException (0xE04030010003)
- Received response from platform: java.lang.NullPointerException (0xE04030010044)
Jak widać w interfejsie użytkownika PowerStore Manager:
Oraz:
Cause
Ten problem występuje w przypadku wystąpienia następującej sekwencji zdarzeń:
Podczas uaktualniania do v2 UUID pakietu dysku jest ustawiony na wartość „null” w bazie danych zarządzania.
Podczas próby uaktualnienia oprogramowania wewnętrznego dysku UUID „null” pakietu powoduje niepowodzenie aktualizacji z błędem java.lang.NullPointerException.
- Pakiet oprogramowania wewnętrznego dysku jest przesyłany, ale nie jest używany.
- Klaster zostaje uaktualniony z PowerStoreOS v1 do PowerStoreOS v2.
- Następuje próba uaktualnienia oprogramowania wewnętrznego dysku za pomocą pakietu przesłanego przed uaktualnieniem PowerStoreOS.
Podczas uaktualniania do v2 UUID pakietu dysku jest ustawiony na wartość „null” w bazie danych zarządzania.
Podczas próby uaktualnienia oprogramowania wewnętrznego dysku UUID „null” pakietu powoduje niepowodzenie aktualizacji z błędem java.lang.NullPointerException.
Resolution
Odwołania do starego pakietu oprogramowania wewnętrznego dysku muszą zostać usunięte ręcznie, a stan aktualizacji wyczyszczony. Po wykonaniu tej czynności pakiet aktualizacji oprogramowania wewnętrznego dysku może zostać przesłany ponownie, a aktualizacja może być kontynuowana.
Skontaktuj się z działem pomocy technicznej firmy Dell EMC lub autoryzowanym przedstawicielem serwisu i podaj identyfikator tego artykułu bazy wiedzy.
Skontaktuj się z działem pomocy technicznej firmy Dell EMC lub autoryzowanym przedstawicielem serwisu i podaj identyfikator tego artykułu bazy wiedzy.
Affected Products
PowerStore, PowerStore 1000X, PowerStore 1000T, PowerStore 3000X, PowerStore 3000T, PowerStore 5000X, PowerStore 5000T, PowerStore 500T, PowerStore 7000X, PowerStore 7000TProducts
PowerStore 9000X, PowerStore 9000TArticle Properties
Article Number: 000196852
Article Type: Solution
Last Modified: 30 Dec 2022
Version: 6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.