PowerStore: O upgrade do firmware de unidade apresenta falha com o erro, Received response from platform: java.lang.NullPointerException
Summary: O upgrade da unidade falha com: Received response from platform: java.lang.NullPointerException (0xE04030010003 or 0xE04030010044)
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
O upgrade da unidade apresenta falha com os erros:
Conforme visto na interface do usuário (IU) do PowerStore Manager
E:
- Upgrade failed on appliance X with the following message: Received response from platform: java.lang.NullPointerException (0xE04030010003)
- Received response from platform: java.lang.NullPointerException (0xE04030010044)
Conforme visto na interface do usuário (IU) do PowerStore Manager
E:
Cause
Esse problema acontece quando ocorre essa sequência de eventos:
Durante o upgrade para v2, o UUID do pacote da unidade é definido como nulo no banco de dados de gerenciamento.
Quando ocorre a tentativa de upgrade do firmware de disco, o UUID de pacote nulo faz com que o upgrade falhe, com o erro java.lang.NullPointerException.
- O pacote de firmware da unidade é carregado, mas não usado.
- O cluster recebe upgrade do PowerStoreOS v1 para o PowerStoreOS v2.
- Ocorre uma tentativa de upgrade de firmware de disco com o pacote que foi carregado antes do upgrade do PowerStoreOS.
Durante o upgrade para v2, o UUID do pacote da unidade é definido como nulo no banco de dados de gerenciamento.
Quando ocorre a tentativa de upgrade do firmware de disco, o UUID de pacote nulo faz com que o upgrade falhe, com o erro java.lang.NullPointerException.
Resolution
As referências ao antigo pacote de firmware da unidade devem ser excluídas manualmente e o estado de upgrade liberado. Assim que isso for feito, o pacote de upgrade do firmware de unidade poderá ser carregado novamente e o upgrade poderá continuar.
Entre em contato com o suporte técnico da Dell EMC ou com seu representante de serviço autorizado e mencione o ID deste artigo da base de conhecimento.
Entre em contato com o suporte técnico da Dell EMC ou com seu representante de serviço autorizado e mencione o ID deste artigo da base de conhecimento.
Affected Products
PowerStore, PowerStore 1000X, PowerStore 1000T, PowerStore 3000X, PowerStore 3000T, PowerStore 5000X, PowerStore 5000T, PowerStore 500T, PowerStore 7000X, PowerStore 7000TProducts
PowerStore 9000X, PowerStore 9000TArticle Properties
Article Number: 000196852
Article Type: Solution
Last Modified: 30 Dec 2022
Version: 6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.