AppSync:升級至 AppSync 4.4 後,遠端 CLI 登入失敗

Summary: 升級到 AppSync 4.4 後,從遠端 CLI 登入 AppSync 伺服器失敗,並顯示錯誤:錯誤:Failed to authenticate USERNAME. 這會在使用 AppSync CLI 時影響手動登入和指令檔登入。

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

升級到 AppSync 4.4 後,從遠端 CLI 登入 AppSync 伺服器失敗,並顯示錯誤:
錯誤:Failed to authenticate USERNAME

這會影響使用者登入中的 CLI,也會影響登入 AppSync 伺服器的指令檔。

從 AppSync 伺服器上的預設 CLI 位置登入 AppSync 會正常運作。AppSync 伺服器上的預設位置為:
C:\EMC\AppSync\appsync-cli

Cause

AppSync 伺服器上已升級的 CLI 未正確複製到遠端 CLI 主機所在的遠端主機。請參閱 AppSync 4.4 User 和管理指南第 3 章。

Resolution

遠端 CLI 應使用 AppSync 4.4 使用者和管理指南中概述的步驟進行更新,如第 3 章:AppSync CLI 公用程式於第 22 頁所述 (擷取如下)。 
 
AppSync CLI 公用程式
AppSync CLI 是與 AppSync 套裝搭配的公用程式,用於透過命令行介面編寫指令碼或執行工作。
AppSync CLI 會安裝在 EMC\AppSync\appsync-cli 目錄中。您可以使用 appsync-cli.bat 檔案在 Windows 上執行。

如果您要使用 UNIX 的 AppSync CLI,請按照以下步驟:
1.將 \EMC\AppSync\appsync-cli 目錄複製到 UNIX 主機。
2.執行 dos2unix appsync-cli.sh。
3.以 chmod +x appsync-cli.sh 提供執行權限。現在您可以使用 appsync-cli.sh 執行所有 CLI
工作。

 
先決條件
  • Java Runtime Environment (JRE) 版本 11 - 必須已安裝並在路徑中提供。
  • OpenJDK 執行時間環境 18.9 (組建 11.0.13+8)。
  • 使用已註冊資源設定 AppSync 安裝
  • 在已註冊主機上探索到的應用程式
  • 配置服務計畫
  • 如果您在非英語主機上使用 CLI,執行前請確保設定好正確的程式碼頁面。若要設定程式碼頁面,請在命令提示字元上使用 chcp。

Products

AppSync, AppSync
Article Properties
Article Number: 000196979
Article Type: Solution
Last Modified: 11 Aug 2022
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.