AppSync:升级到 AppSync 4.4 后,远程 CLI 登录失败

Summary: 升级到 AppSync 4.4 后,从远程 CLI 登录 AppSync 服务器失败,并显示错误:ERROR: Failed to authenticate USERNAME. 这会在使用 AppSync CLI 时影响手动登录和脚本化登录。

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

升级到 AppSync 4.4 后,从远程 CLI 登录 AppSync 服务器失败,并显示错误:
ERROR: Failed to authenticate USERNAME

这会影响有活动用户登录的 CLI 以及登录 AppSync 服务器的脚本。

从 AppSync 服务器上的默认 CLI 位置则可正常登录 AppSync。AppSync 服务器上的默认位置是:
C:\EMC\AppSync\appsync-cli

Cause

AppSync 服务器上的升级 CLI 未正确复制到远程 CLI 主机所在的远程主机。请参阅《AppSync 4.4 用户和管理指南》第 3 章。

Resolution

要更新远程 CLI,请使用《AppSync 4.4 用户和管理指南》第 3 章:AppSync CLI 实用程序第 22 页中所述的步骤(摘录如下)。 
 
AppSync CLI 实用程序
AppSync CLI 是 AppSync 中随附的实用程序,用于通过命令行界面编写脚本或运行任务。
AppSync CLI 安装在 EMC\AppSync\appsync-cli 目录中。在 Windows 上,您可以使用文件 appsync-cli.bat 运行它。

如果您想要在 UNIX 中使用 AppSync CLI,请执行以下步骤:
1.将 \EMC\AppSync\appsync-cli 目录复制到 UNIX 主机。
2.运行 dos2unix appsync-cli.sh。
3.使用 chmod +x appsync-cli.sh 提供执行权限。现在,您可以使用 appsync-cli.sh 来执行所有 CLI 任务。

 
前提条件
  • Java Runtime Environment (JRE) 版本 11 — 必须安装并在路径中可用。
  • OpenJDK Runtime Environment 18.9(内部版本 11.0.13+8)。
  • 使用已注册的资源配置 AppSync 安装
  • 在已注册的主机上发现应用程序
  • 配置服务计划
  • 如果您在非英语版本的主机上使用 CLI,请确保在执行之前设置正确的代码页。要设置代码页,请在命令提示符上使用 chcp。

Products

AppSync, AppSync
Article Properties
Article Number: 000196979
Article Type: Solution
Last Modified: 11 Aug 2022
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.