AppSync: utenti e gruppi LDAP non sono presenti nella configurazione di AppSync dopo l'aggiornamento ad AppSync 4.4.0.0 o 4.4.1.0

Summary: utenti LDAP e gruppi LDAP non sono presenti nell'interfaccia utente di AppSync in "Settings > User, Group, and Roles" dopo l'aggiornamento ad AppSync 4.4.0.0 o 4.4.1.0.

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Symptoms

Gli utenti LDAP e i gruppi LDAP non sono disponibili nell'interfaccia utente di AppSync in Settings > User, Group, and Roles dopo l'aggiornamento ad AppSync 4.4.0.0 o 4.4.1.0.

Il registro dell'aggiornamento di AppSync in riporta:
Command.run(): C:\Users\Administrator\AppData\Local\Temp\2\721210.tmp\executeScriptTmp0.bat:stdout [Successfully configured LDAP User xxxxxxx]
Command.run(): C:\Users\Administrator\AppData\Local\Temp\2\721210.tmp\executeScriptTmp0.bat:stdout [Begin configuring the LDAP User]
Command.run(): C:\Users\Administrator\AppData\Local\Temp\2\721210.tmp\executeScriptTmp0.bat:stdout [An error occured while adding the LDAP user xxxxxx]
Command.run(): C:\Users\Administrator\AppData\Local\Temp\2\721210.tmp\executeScriptTmp0.bat:stdout [An error occured while adding the LDAP user yyyyyyyyy]
Command.run(): C:\Users\Administrator\AppData\Local\Temp\2\721210.tmp\executeScriptTmp0.bat:stdout [Begin configuring the LDAP group]
Command.run(): C:\Users\Administrator\AppData\Local\Temp\2\721210.tmp\executeScriptTmp0.bat:stdout [An error occured while adding the LDAP group gggggggg]
Command.run(): C:\Users\Administrator\AppData\Local\Temp\2\721210.tmp\executeScriptTmp0.bat:stdout [An error occured while adding the LDAP group gggggggggg1]

Uno dei possibili sintomi è che AppSync non è in grado di cercare utenti e gruppi a livello di sottoalbero quando nel percorso di ricerca sono definiti solo DC=appxycnee,DC=lab.

Quando si tenta di aggiungere un utente o un gruppo nell'interfaccia utente di AppSync, viene visualizzato il seguente errore:
User "ABCDEFGH" could not be found on the LDAP server. Check the spelling and/or verify if the user exists on the LDAP server. And also verify user attributes in LDAP configuration settings.

Tuttavia, la configurazione LDAP funziona come previsto quando il percorso di ricerca degli utenti e il percorso di ricerca dei gruppi vengono aggiornati con i dettagli su CN e OU.

Il server LDAP funziona aggiungendo quanto segue quando vengono specificati i livelli del sottoalbero:
Example: CN:users,OU=people,DC=appxycnee,DC=lab

Non funziona invece quando viene specificato solo il livello base:
Example: DC=appxycnee,DC=lab

Cause

Durante l'aggiornamento ad AppSync 4.4.0.0, AppSync esegue il backup dei dati di utenti e gruppi da CST/Lockbox in una tabella temporanea nella memoria persistente di AppSync. Dopo l'aggiornamento, gli utenti e i gruppi vengono importati in Keycloak. Al termine dell'importazione, AppSync elimina i dati dalla tabella temporanea. In questo caso, l'operazione di importazione degli utenti non è riuscita in quanto AppSync non è stata in grado di cercare nel server LDAP il percorso di utenti e gruppi a livello di sottoalbero. 

Lo stesso problema è presente anche in AppSync 4.4.1.0.
Le note di rilascio per 4.4.1.0 segnalano erroneamente che sono inclusi APPSYNC-3824 e APPSYNC-3743.

Resolution

È disponibile un hotfix per AppSync 4.4.0.0 e 4.4.1.0. Citare questo numero di articolo quando si chiama il supporto Dell per aprire una Service Request e ottenere l'hotfix.

L'hotfix consente ad AppSync di eseguire la ricerca a livello di sottoalbero (nomi OU e CN) anche quando sono stati definiti controller di dominio, con il solo livello base DC=appcycnee,DC=lab definito nella stringa di ricerca. L'hotfix consente ad AppSync di cercare tutti gli utenti e i gruppi, come illustrato di seguito nella struttura di AS: 
appsyncee.lab\Users\User1
appsyncee.lab\Managed\User2
 
Successivamente all'applicazione dell'hotfix, la definizione LDAP deve essere rimossa e poi aggiunta di nuovo in AppSync. Questo passaggio è essenziale e l'hotfix non funziona fino a quando la definizione LDAP in AppSync non viene rimossa e poi aggiunta di nuovo.

È possibile aggiungere di nuovo utenti e gruppi LDAP.

Riepilogando: 
  1. Installare l'hotfix.
  2. Rimuovere e aggiungere di nuovo le impostazioni LDAP. Questo passaggio è obbligatorio. L'hotfix non funziona se non viene eseguita questa operazione. Il percorso di ricerca può essere a livello di controller di dominio se richiesto dalla risoluzione dell'hotfix (CN e OU non richiesti con l'hotfix). 
  3. Aggiungere utenti e gruppi all'interfaccia utente di AppSync.

Products

AppSync, AppSync
Article Properties
Article Number: 000197466
Article Type: Solution
Last Modified: 14 Dec 2022
Version:  5
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