AppSync:AppSync 4.4.0.0または4.4.1.0にアップグレードした後、AppSync構成にLDAPユーザーとグループが見つからない

Summary: AppSync 4.4.0.0または4.4.1.0へのアップグレード後、AppSync UIの「Settings > User, Group, and Roles」にLDAPユーザーとLDAPグループがありません。

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Symptoms

AppSync 4.4.0.0または4.4.1.0へのアップグレード後、AppSync UIの「Settings > User, Group, and Roles」にLDAPユーザーとLDAPグループがありません。

のAppSyncアップグレート ログには、次のように表示されます。
Command.run(): C:\Users\Administrator\AppData\Local\Temp\2\721210.tmp\executeScriptTmp0.bat:stdout [Successfully configured LDAP User xxxxxxx]
Command.run(): C:\Users\Administrator\AppData\Local\Temp\2\721210.tmp\executeScriptTmp0.bat:stdout [Begin configuring the LDAP User]
Command.run(): C:\Users\Administrator\AppData\Local\Temp\2\721210.tmp\executeScriptTmp0.bat:stdout [An error occured while adding the LDAP user xxxxxx]
Command.run(): C:\Users\Administrator\AppData\Local\Temp\2\721210.tmp\executeScriptTmp0.bat:stdout [An error occured while adding the LDAP user yyyyyyyyy]
Command.run(): C:\Users\Administrator\AppData\Local\Temp\2\721210.tmp\executeScriptTmp0.bat:stdout [Begin configuring the LDAP group]
Command.run(): C:\Users\Administrator\AppData\Local\Temp\2\721210.tmp\executeScriptTmp0.bat:stdout [An error occured while adding the LDAP group gggggggg]
Command.run(): C:\Users\Administrator\AppData\Local\Temp\2\721210.tmp\executeScriptTmp0.bat:stdout [An error occured while adding the LDAP group gggggggggg1]

考えられる現象は、検索パスで「DC=appxycnee,DC=lab」のみが定義されている場合に、AppSyncがサブツリー レベルからのユーザーとグループの検索に失敗することです。

AppSync UIでユーザーまたはグループを追加しようとすると、次のエラーが表示されます。
User "ABCDEFGH" could not be found on the LDAP server. Check the spelling and/or verify if the user exists on the LDAP server. And also verify user attributes in LDAP configuration settings.

ただし、ユーザー検索パスグループ検索パスがCNおよびOUの詳細で更新されると、LDAP構成は正常に機能します。

サブツリー レベルが指定されている場合、LDAPサーバーは次のように動作します。
Example: CN:users,OU=people,DC=appxycnee,DC=lab

その後、ベース レベルのみを指定していると、次のように失敗します。
Example: DC=appxycnee,DC=lab

Cause

AppSync 4.4.0.0へのアップグレードの一環として、AppSyncはユーザーとグループの詳細をCST/LockboxからAppSyncのデータ保全の一時的なテーブルにバックアップします。アップグレード後の操作では、ユーザーとグループはkeycloakにインポートされます。インポート操作が正常に完了すると、AppSyncは一時的なテーブルからデータを削除します。この場合、AppSyncがサブツリー レベルでユーザーおよびグループ検索パスに対してLDAPサーバーを検索できなかったため、ユーザー のインポート操作が失敗しました。

AppSync 4.4.1.0でも同じ問題が発生します。
4.4.1.0のリリース ノートには、APPSYNC-3824およびAPPSYNC-3743が含まれていると誤って記載されています。

Resolution

AppSync 4.4.0.0および4.4.1.0のホットフィックスが存在します。ホットフィックスを取得するためのサービス リクエストを開くためにDellサポートに電話する場合は、この記事番号をお伝えください。

このホットフィックスを使用すると、DCが定義されている場合でも、検索文字列にベース レベル「DC=appcycnee,DC=lab」のみが定義されている場合は、AppSyncはサブツリー レベル(OUおよびCN名)で検索できます。このホットフィックスを使用すると、以下に示すように、AppSyncはAS構造ですべてのユーザーとグループを検索できます。 
appsyncee.lab\Users\User1
appsyncee.lab\Managed\User2
 
ホットフィックスの適用後、AppSyncのLDAP定義を削除して再度追加する必要があります。これは重要なステップであり、AppSyncのLDAP定義が削除されて再度追加されるまで、ホットフィックスは機能しません。

LDAPユーザーとグループは再度追加される場合があります。

まとめ: 
  1. ホットフィックスをインストールします。
  2. LDAP設定を削除して再度追加します。これは必須の手順です。ホットフィックスは、これが実行されない限り機能しません。ホットフィックスの解決に必要な場合は、検索パスをDCレベルにすることができます(ホットフィックスではCNとOUは必要ありません)。 
  3. AppSync UIにユーザーとグループを追加します。

Products

AppSync, AppSync
Article Properties
Article Number: 000197466
Article Type: Solution
Last Modified: 14 Dec 2022
Version:  5
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